summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohn K. Luebs2020-03-28 22:00:15 -0400
committerJohn K. Luebs2020-03-28 22:00:15 -0400
commit7968539a0e8a902bed202c0a4d89b8b3880ca9cf (patch)
treeb265153ce12719273ba1ac22361911cf8b6909e6 /PKGBUILD
downloadaur-7968539a0e8a902bed202c0a4d89b8b3880ca9cf.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9161557a619b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: John K. Luebs <jkl at johnluebs dot tld>
+
+pkgname=gitea-tea
+_pkgname=tea
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="Painless self-hosted Git service.."
+arch=(x86_64)
+url="https://gitea.io"
+license=(MIT)
+makedepends=(go-pie)
+_tag=12f38c892f5d34ea58edd6fda15e7f0691d8d7cd
+source=("git+https://gitea.com/gitea/tea.git#tag=${_tag}")
+sha256sums=(SKIP)
+
+build() {
+ cd ${_pkgname}
+ go build -mod=vendor \
+ -trimpath \
+ -ldflags "-extldflags $LDFLAGS" .
+}
+
+package() {
+ cd ${_pkgname}
+
+ install -Dm755 ${_pkgname} -t "${pkgdir}"/usr/bin/
+ install -Dm755 LICENSE -t "${pkgdir}"/usr/share/licenses/${pkgname}/
+}