summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSebastian Lau2016-04-11 09:11:55 +0200
committerSebastian Lau2016-04-11 09:11:55 +0200
commit6f77fa129a88f0c6ab16281beb5f66bb778f4d49 (patch)
treedd4f649ef382f4fdee122ca233d5eaaf03fe74aa /PKGBUILD
parent17d9ec3dd1017abdb2c9c397211771af81505d2a (diff)
downloadaur-6f77fa129a88f0c6ab16281beb5f66bb778f4d49.tar.gz
Update to 1.12.0
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD25
1 files changed, 15 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d256f5226a2d..9a37d4e9eb68 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
-# Maintainer : Sebastian Lau <lauseb644@gmail.com>
+# Maintainer : Sebastian Lau <lauseb644 _at_ gmail .dot. com>
# Contributor: Martin Wimpress <code@flexion.org>
# Contributor: Liganic <liganic-aur@gmx.org>
# Contributor: Bernd Amend <berndamend@web.de>
# Contributor: Holodoc <archlinux@bananapro.de>
pkgname=giteye
-pkgver=1.11.0
+pkgver=1.12.0
pkgrel=1
pkgdesc="A desktop for Git. It works with TeamForge, CloudForge, GitHub and other Git services."
arch=('i686' 'x86_64')
@@ -16,16 +16,16 @@ makedepends=('unzip')
options=('!strip')
source=("LICENSE"
"${pkgname}.desktop")
-md5sums=('4df23a2c4f45c567feae7665694cd11a'
+md5sums=('29a5e78a36cabce86274d07ea11dd502'
'3144b18d4ddf6ac166afe374872ce4b4')
-md5sums_x86_64=('a6c3e91d9dee12877a27aafabc77f38e')
-md5sums_x86=('2ab57f083344ead599d0f64b811adc36')
+md5sums_i686=('02909e014f13dd29127887b02dbad1eb')
+md5sums_x86_64=('ecff81dcaee493852ea66a105948af13')
-_subfolder="61/11867"
+_subfolder="61/12536"
_antver="1.9.4.v201504302020"
source_x86_64=("https://downloads-guests.open.collab.net/files/documents/${_subfolder}/GitEye-${pkgver}-linux.x86_64.zip")
-source_x86=("https://downloads-guests.open.collab.net/files/documents/${_subfolder}/GitEye-${pkgver}-linux.x86.zip")
+source_i686=("https://downloads-guests.open.collab.net/files/documents/${_subfolder}/GitEye-${pkgver}-linux.x86.zip")
noextract=(*.zip) # extract nothing
@@ -35,14 +35,19 @@ package() {
msg2 "Extracting GitEye from archive..."
install -Ddm755 "${pkgdir}/opt/${pkgname}/"
install -Ddm755 "${pkgdir}/usr/bin/"
- unzip -q ${noextract} -d "${pkgdir}/opt/${pkgname}/"
+
+ if [[ "$CARCH" = "i686" ]]; then
+ unzip -q "GitEye-${pkgver}-linux.x86.zip" -d "${pkgdir}/opt/${pkgname}/"
+ else
+ unzip -q "GitEye-${pkgver}-linux.x86_64.zip" -d "${pkgdir}/opt/${pkgname}/"
+ fi
msg2 "Linking executable..."
ln -s "/opt/${pkgname}/GitEye" "${pkgdir}/usr/bin/"
msg2 "Installing LICENSE..."
- if [[ "$CARCH" = "x_86_64" ]]; then
- sed -i 's/32-bit/64-bit/' LICENSE
+ if [[ "$CARCH" = "i686" ]]; then
+ sed -i 's/64-bit/32-bit/' LICENSE
fi
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"