summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhil Ruffwind2019-01-12 23:25:36 -0800
committerPhil Ruffwind2019-01-13 00:06:14 -0800
commit05459d80d961156107c7fa5748b2f14daadf3a9d (patch)
treeb7e37acb1d885cf61f4bb993f57ce4996340f0f9 /PKGBUILD
parentd92bd130a85835477a278e2fcae52c7e0c05f3f8 (diff)
downloadaur-05459d80d961156107c7fa5748b2f14daadf3a9d.tar.gz
Disable plugins support
Plugins don't work. One issue was the missing "lib/ghc-8.6.3/settings", caused by the use of a throwaway GHC installation. This could be mitigated by switching to a permanent GHC installation (e.g. by creating a separate AUR package for GHC pinned to 8.6). However, plugins in Gitit are still not usable because they cannot be compiled without libraries. Bundling libraries with this package isn't a good idea because 1. it can only be achieved by turning this into a binary package due to limitations of Haskell's build tools, and 2. even if problem 1 is fixed, the plugins are limited to just the bundled libraries. Remark on problem 1: It is necessary have to bundle the gitit libraries and all its dependencies. makepkg requires packages to be built in a "staged" directory ($pkgdir) that isn't the final destination of these files. Since cabal sandboxes are not relocatable ( see for example https://github.com/haskell/cabal/issues/4097 ), nor does cabal support building in staged sandboxes, the only solution would be to package gitit as a binary tarball, which is undesirable. As a result, plugin support will be disabled entirely, which shaves off like 60MiB of space. Users who wish to use gitit with plugins should consider building and running gitit with cabal + ghc-pristine. For example: sudo pacman -S --needed cabal-install ghc-static git mailcap zlib curl -L https://aur.archlinux.org/cgit/aur.git/snapshot/ghc-pristine.tar.gz | tar -xz (cd ghc-pristine && makepkg -i) git clone https://github.com/jgm/gitit cd gitit cabal v2-update cabal v2-configure --with-compiler=/usr/share/ghc-pristine/bin/ghc cabal v2-run -- gitit -f example.conf
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 60c4aed63b61..538ed00f97d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Phil Ruffwind <rf@rufflewind.com>
pkgname=gitit
pkgver=0.12.3.1
-pkgrel=1
+pkgrel=2
pkgdesc="A wiki backed by a git, darcs, or mercurial filestore"
arch=(i686 x86_64)
url=https://hackage.haskell.org/package/gitit
license=(GPL)
-depends=(libffi gmp mailcap zlib)
+depends=(gmp mailcap numactl zlib)
optdepends=("git: git support" "mercurial: mercurial support")
-makedepends=(cabal-install ncurses5-compat-libs numactl)
+makedepends=(cabal-install libffi ncurses5-compat-libs)
source=(haskell-ConfigFile-1.1.4.tar.gz::https://hackage.haskell.org/package/ConfigFile-1.1.4/ConfigFile-1.1.4.tar.gz
haskell-Diff-0.3.4.tar.gz::https://hackage.haskell.org/package/Diff-0.3.4/Diff-0.3.4.tar.gz
haskell-Glob-0.9.3.tar.gz::https://hackage.haskell.org/package/Glob-0.9.3/Glob-0.9.3.tar.gz
@@ -401,7 +401,7 @@ EOF
build() {
unset CABAL_SANDBOX_CONFIG CABAL_SANDBOX_PACKAGE_PATH GHC_PACKAGE_PATH
- cabal --config=.cabal/config v1-install --enable-relocatable --force-reinstalls --datadir='$prefix/share/gitit' --docdir='$prefix/share/doc/$abi/$pkgid' --ghc-options=-rtsopts gitit
+ cabal --config=.cabal/config v1-install --enable-relocatable --force-reinstalls -f-plugins --datadir='$prefix/share/gitit' --docdir='$prefix/share/doc/$abi/$pkgid' --ghc-options=-rtsopts gitit
}
package() {