summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhil Ruffwind2021-05-31 13:15:16 -0700
committerPhil Ruffwind2021-05-31 13:16:07 -0700
commit468cb35201aaaaabc3cf1e6ce66cfd54a42ed113 (patch)
treea308d7a6f166992c15290dd86054dbebd686f293 /PKGBUILD
parent6338ca11beb23374e668487ece45546261c65e06 (diff)
downloadaur-468cb35201aaaaabc3cf1e6ce66cfd54a42ed113.tar.gz
Use GHC from external packages instead
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 2 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9e48e70c57d1..716470be1719 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ url=https://hackage.haskell.org/package/gitit
license=(GPL)
depends=(gmp mailcap numactl zlib)
optdepends=("git: git support" "mercurial: mercurial support")
-makedepends=(cabal-install libffi ncurses5-compat-libs)
+makedepends=(cabal-install ghc8.8)
source=(haskell-ConfigFile-1.1.4.tar.gz::https://hackage.haskell.org/package/ConfigFile-1.1.4/ConfigFile-1.1.4.tar.gz
haskell-Diff-0.4.0.tar.gz::https://hackage.haskell.org/package/Diff-0.4.0/Diff-0.4.0.tar.gz
haskell-Glob-0.10.1.tar.gz::https://hackage.haskell.org/package/Glob-0.10.1/Glob-0.10.1.tar.gz
@@ -405,22 +405,13 @@ sha512sums=('4455110c95172461b2d82ae88ba4f386d5e49ddd7f7def83714d2f6198090f0d121
'd75097619e9d999f84e80e8fe7f541e3df81289ce40763f9193460e23a0dcb0d37c5cad7ce6b0fe7a8f32d856e4b231bc83dab34729248a6bf1dda1377b94691'
'216555bd73a46da5061291c2c071e9c71239bd5ae253ac06ee80ade65bb1871366cc8e4dffbad983c5b6a7f4b0cb2a1439dfa5971db3e183124fa90442a73f0c'
'3619b5c32e16a4fb9a68a9e6ea0beb9b14d06a4b5825811f429ee232a0ea13035335cd86c0301f8afcff126a473b86698fd310f9608e0e0ecb849714842be1ea')
-sha512sums_i686=('519eaf812c86d8d7bc92999ecc16b9994803927e1e56adcc69bc83c66c8ba5ec43caf2727ff905310c78d08b78afc03892ccc76f9268b2325c2915cab3ceadcf')
-sha512sums_x86_64=('4c508b5a717a3598ebe8f88c0dd8ffe077115c1a91197af4ce9e25e8bfde445adb98efde9b35edcd1a4896870f505f67029b16c3ed89ac01c986f2afc2ed09b7')
noextract=("${source[@]%%::*}")
-source_i686=("https://downloads.haskell.org/~ghc/8.8.4/ghc-8.8.4-i386-deb9-linux.tar.xz")
-source_x86_64=("https://downloads.haskell.org/~ghc/8.8.4/ghc-8.8.4-x86_64-deb9-linux.tar.xz")
prepare() {
unset CABAL_SANDBOX_CONFIG CABAL_SANDBOX_PACKAGE_PATH GHC_PACKAGE_PATH
- (
- cd ghc-8.8.4
- ./configure --prefix="$srcdir/.local"
- make install
- )
mkdir -p .cabal
cat >.cabal/config <<EOF
-with-compiler: $srcdir/.local/bin/ghc
+with-compiler: ghc-8.8
jobs: \$ncpus
EOF
cabal --config=.cabal/config v1-sandbox init