summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhil Ruffwind2017-08-31 14:41:43 -0400
committerPhil Ruffwind2017-08-31 14:49:34 -0400
commit85e184d1264ae6c1a8469b1da7db3595ff075095 (patch)
tree355e510c069143424e776f497e649260f197b9af /PKGBUILD
parent98e9e09c6e3ca234bca6411f000fafad2c6087df (diff)
downloadaur-85e184d1264ae6c1a8469b1da7db3595ff075095.tar.gz
Remove ncurses5-compat-libs from dependencies
Some other minor fixes: - Improve error message about BUILDDIR being too small - Create $pkgdir/usr/bin if absent (otherwise stack install fails) - Add $pkgdir/usr/bin to PATH to avoid warnings from stack
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f8e0bfbf4a38..f01471251131 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,29 @@
# Maintainer: Phil Ruffwind <rf@rufflewind.com>
pkgname=gitit
pkgver=0.12.2.1
-pkgrel=1
+pkgrel=2
pkgdesc="A wiki backed by a git, darcs, or mercurial filestore"
arch=(i686 x86_64)
-url=https://hackage.haskell.org/package/$pkgname
+url=https://hackage.haskell.org/package/gitit
license=(GPL)
depends=(gmp zlib)
optdepends=("git: git support" "mercurial: mercurial support")
-makedepends=(ncurses5-compat-libs stack)
-source=(https://github.com/jgm/$pkgname/archive/$pkgver.tar.gz)
+makedepends=(stack)
+source=(https://github.com/jgm/gitit/archive/$pkgver.tar.gz)
sha256sums=('017cd716c8844036600e8aee858861ac41d8ef3c1ab02b43cd50532e4d5472b9')
build() {
if [ `df -P "$srcdir" | awk 'NR==2 {print $4}'` -lt 8388608 ]; then
- echo >&2 "Error: need at least 8GiB of space in $srcdir"
+ echo >&2 "Error: need >= 8GiB in $srcdir; set BUILDDIR to something else"
return 1
fi
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/gitit-$pkgver"
stack --stack-root "$srcdir/.stack" --install-ghc build --ghc-options=-rtsopts
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- stack --stack-root "$srcdir/.stack" install --local-bin-path "$pkgdir/usr/bin"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "$srcdir/gitit-$pkgver"
+ mkdir -p "$pkgdir/usr/bin"
+ PATH=$pkgdir/usr/bin:$PATH stack --stack-root "$srcdir/.stack" install --local-bin-path "$pkgdir/usr/bin"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/gitit/LICENSE"
}