summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhil Ruffwind2018-02-04 12:39:46 -0500
committerPhil Ruffwind2018-02-04 12:39:49 -0500
commitfac351d9a35d0b2ecfc554df8327a108eade4197 (patch)
tree1d5ffd6fac6df736f799e5d0f14cbba89fa150b0 /PKGBUILD
parent6cc3311c64804ae5a3283fdde366d1ca0f703839 (diff)
downloadaur-fac351d9a35d0b2ecfc554df8327a108eade4197.tar.gz
Work around incompatibility between MissingH 1.4.0.1 and parsec 3.1.12.0
For now, we avoid parsec 3.1.12.0 until incompatibility is fixed. See: https://github.com/jgoerzen/missingh/issues/42 https://github.com/haskell/parsec/issues/88
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8cfb5eaa5583..523e5e7dcd7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,7 +27,7 @@ build() {
cd "$srcdir/gitit-$pkgver"
cabal --config="$srcdir/.cabal/config" update
cabal --config="$srcdir/.cabal/config" sandbox init
- cabal --config="$srcdir/.cabal/config" install --enable-relocatable --force-reinstalls --datadir='$prefix/share/gitit' --docdir='$prefix/share/doc/$abi/$pkgid' --ghc-options=-rtsopts --constraint='pandoc>=1.19.2.2'
+ cabal --config="$srcdir/.cabal/config" install --enable-relocatable --force-reinstalls --datadir='$prefix/share/gitit' --docdir='$prefix/share/doc/$abi/$pkgid' --ghc-options=-rtsopts --constraint='pandoc>=1.19.2.2' --constraint='parsec<3.1.12.0'
}
package() {