summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorimlonghao2020-10-12 16:16:38 +0000
committerimlonghao2020-10-12 16:16:38 +0000
commitc25be6cd7b5ce456a8a66564b06fa40f3b45d8b0 (patch)
tree25ea51f5218408ab7d33bc944749a01eea5877fe /PKGBUILD
downloadaur-c25be6cd7b5ce456a8a66564b06fa40f3b45d8b0.tar.gz
New package gitjacker
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..62a8f2af84a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Hao Long <aur@esd.cc>
+
+pkgname=gitjacker
+pkgver=0.0.2
+pkgrel=1
+pkgdesc="Leak git repositories from misconfigured websites"
+arch=("x86_64" "i686")
+url="https://github.com/liamg/gitjacker"
+license=("Unlicense")
+depends=("glibc")
+makedepends=("go")
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('429dc9d83921c675cff87f9904c627657df87da7fb61a21ac00c5860828cacad')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ go build -buildmode=pie -trimpath -modcacherw -mod=vendor -o=gitjacker \
+ -ldflags="-linkmode=external -X=github.com/liamg/gitjacker/internal/app/version.Version=v${pkgver}" \
+ cmd/gitjacker/main.go
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ install -Dm755 gitjacker ${pkgdir}/usr/bin/${pkgname}
+}