summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2018-07-03 10:31:59 +0000
committerCaleb Maclennan2018-07-03 11:44:32 +0000
commit1db7f95a1b4d152411eef427034377e5eded26fe (patch)
tree2bf96eb82d238ee205646a7a4dc845c91a95eedb /PKGBUILD
parentd80024dcd039c6add8829780558f99750fa90a97 (diff)
downloadaur-1db7f95a1b4d152411eef427034377e5eded26fe.tar.gz
Update to 11.0.2 and sync with [community]/gitlab
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD67
1 files changed, 22 insertions, 45 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 93554b60345a..18e63a8efce8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Michael Taboada <michael@2mb.solutions>
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+# Contributor: Michael Taboada <michael@2mb.solutions>
# Contributor: Janne Heß<jannehess@gmail.com>
# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
# Contributor: Pavol (Lopo) Hluchy <lopo AT losys DOT eu>
@@ -6,12 +7,11 @@
# Contributor: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
# Contributor: Tobias Hunger <tobias DOT hunger AT gmail DOT com>
# Contributor: Stefan Tatschner <stefan@sevenbyte.org>
-# Contributor: Caleb Maclennan <caleb@alerque.com>
_pkgname=gitlab
pkgname=${_pkgname}-ee
-pkgver=10.7.1
-pkgrel=4
+pkgver=11.0.2
+pkgrel=1
pkgdesc="Project management and code hosting application"
arch=('x86_64')
url="https://gitlab.com/gitlab-org/gitlab-ee"
@@ -19,8 +19,8 @@ license=('MIT')
conflicts=("${_pkgname}")
provides=("${_pkgname}")
options=(!buildflags)
-depends=('ruby2.3' 'git' 'ruby2.3-bundler' 'gitlab-workhorse' 'gitlab-gitaly' 'openssh' 'redis' 'libxslt' 'icu' 'nodejs' 're2')
-makedepends=('cmake' 'postgresql' 'mariadb' 'yarn' 'go')
+depends=('ruby2.3' 'git' 'ruby2.3-bundler' 'gitlab-workhorse' 'gitlab-gitaly' 'openssh' 'redis' 'libxslt' 'icu' 're2' 'http-parser')
+makedepends=('cmake' 'postgresql' 'mariadb' 'yarn' 'go' 'nodejs')
optdepends=('postgresql: database backend'
'mysql: database backend'
'python2-docutils: reStructuredText markup language support'
@@ -30,7 +30,7 @@ backup=("etc/webapps/${_pkgname}/application.rb"
"etc/webapps/${_pkgname}/resque.yml"
"etc/webapps/${_pkgname}/unicorn.rb"
"etc/logrotate.d/${_pkgname}")
-source=("${pkgname}-${pkgver}.tar.bz2::https://gitlab.com/gitlab-org/gitlab-ee/repository/archive.tar.bz2?ref=v${pkgver}-ee"
+source=("${pkgname}-${pkgver}.tar.gz::https://gitlab.com/api/v4/projects/gitlab-org%2Fgitlab-ee/repository/archive?sha=v${pkgver}-ee"
gitlab-unicorn.service
gitlab-sidekiq.service
gitlab-backup.service
@@ -39,15 +39,9 @@ source=("${pkgname}-${pkgver}.tar.bz2::https://gitlab.com/gitlab-org/gitlab-ee/r
gitlab.target
gitlab.tmpfiles.d
gitlab.logrotate
- apache.conf.example
- apache-ssl.conf.example
- apache2.2.conf.example
- apache2.2-ssl.conf.example
- nginx.conf.example
- nginx-ssl.conf.example
- lighttpd.conf.example)
+ "b41b2de702c26bfbbe375c70c48293a75546df42.patch::https://git.archlinux.org/svntogit/community.git/plain/trunk/b41b2de702c26bfbbe375c70c48293a75546df42.patch?h=packages/gitlab")
install='gitlab.install'
-sha512sums=('22e1436c782b5a44aa9d51c6f08e687af1ebc6745aa85ebf796270e05a7b0740dc821a915d53577467d4b132e3000673452a67c3ee4432dabbd61c7c3bbc56c7'
+sha512sums=('c4413b59212fb34197d6b2ef8d57635290768ad8f1fc4baa2e2ee0636e58c67965bbbd43dcafca72d9c3ac2c4f1104873b58d183a642f4797aa838211578f687'
'e96364b3373420a0704552584264f42fee23d64d44d3f769dffa6b516ea9d4c09873da8b2a279445ae9a09f17f81628815efc83e8d0070b3246e56aa13c02ac6'
'1104db0397ae5f9a69452ea2a432b837cfaf37d72d063226c2156de5f753b5ae42be1f90292c34f27e251ce3d265ac9c1f79faad1d377c923e7dbc6744100471'
'bfc98f3890dfbe11a6f7fa3275f2b04b54b8e31455dcf70abfdc7f1021ff9acb1243f7af8381465346cd780bc76fa2b1c80fada860b8c3c87c7c56bb5229c1ee'
@@ -56,13 +50,7 @@ sha512sums=('22e1436c782b5a44aa9d51c6f08e687af1ebc6745aa85ebf796270e05a7b0740dc8
'bf33b818e4ea671c16f58563997ba5fe0a09090e5c03577ff974d31324d4e9782b85a9bb4f1749b97257ce93400c692de935f003770d52b5994c9cab9aee57c6'
'abacbff0d7be918337a17b56481c84e6bf3eddd9551efe78ba9fb74337179e95c9b60f41c49f275e05074a4074a616be36fa208a48fc12d5b940f0554fbd89c3'
'20b93eab504e82cc4401685b59e6311b4d2c0285bc594d47ce4106d3f418a3e2ba92c4f49732748c0ba913aa3e3299126166e37d2a2d5b4d327d66bae4b8abda'
- '441585489fb992d5e893f14bf0770df04ada95ffdbfcc80bb98a44eda7db520d12c985f600d003d80a196562654d2231598f8481ff9bf664bb5889f564e897e7'
- '99f31439d348e21f764875b6207db8663b47f3224ad6a9f35b89c8a2ed29a9e831a974aa6b9429a3882fb74c1c9d42ed5c38b2d16ae122b5d55d5873a0c57cd3'
- '624eb1f13e0265522290faa8c22b4150e6081ca2580391c9dfd871f1ee1b9c1c745c95d3d8f7fdbf85038990060141b844c3d8097c577ab68e5506bfa2d2dddb'
- '248d47b44fa5ed65e2a940f2b60d0482c481b3a438357ca510848221370367ffbc0d83ce046d688bebbbc75d4e321b140f6a5ce1a9d7ec0b034fafcf92dee107'
- '53a9d6d6f87874b29e48a8fb2e207094ebc1a80af478562ec4b591926d59e135a3166c20966704aa948ca7063ba63c1ec4ac290a343832fa18025ec3d85081ba'
- '6d3006da591acefcc534c6e3f1da8e812d0b3b21fc416bfaa8678b8e2d922be6b17d1c92b0d7164de3b8ad864139253707107ca082f78e823d23f3b65fcb5914'
- 'c78b6f46abcf603d8db6e38cf50868e14145928422ddfe17c88e2f006b5b910dddf456ec5d6d724b250994530643963809688a98f7e12ebd5b5dabf7f96f0e06')
+ '32c432bf5e45be7b63e078335deaab5d05f8c0e78da891038cc607beed75c670f4c825138bb2c6ba0b4cf879ef45f5cbeb12cebd4fa63d7f58362960788c9e72')
_datadir="/usr/share/webapps/${_pkgname}"
_etcdir="/etc/webapps/${_pkgname}"
@@ -71,16 +59,15 @@ _logdir="/var/log/${_pkgname}"
_srcdir="${pkgname}-v${pkgver}-ee-"
prepare() {
- cd "${srcdir}"
-
# Get first 7 characters from sha1 which has 40 characters in total
local revision=$(ls -d ${_srcdir}* | rev | cut -c 34-40 | rev)
cd "${_srcdir}"*
- msg2 "Patching git revision in config/initializers/2_app.rb..."
- sed -i -e "s|REVISION = Gitlab::Popen.popen(%W(#{config.git.bin_path} log --pretty=format:%h -n 1)).first.chomp.freeze|REVISION = \"${revision}\"|" \
- config/initializers/2_app.rb
+ # patch -Np1 -i "${srcdir}"/b41b2de702c26bfbbe375c70c48293a75546df42.patch
+
+ # GitLab tries to read its revision information from a file.
+ echo "${revision}" > REVISION
export SKIP_STORAGE_VALIDATION='true'
@@ -136,20 +123,12 @@ build() {
cp config/resque.yml.example config/resque.yml
sed -i 's/url.*/nope.sock/g' config/resque.yml
- #we need to get rid of the custom paths in case someone has gitlab already installed.
- mv config/gitlab.yml config/gitlab.yml.bak
- # and create default
- cp config/gitlab.yml.example config/gitlab.yml
-
yarn install --production --pure-lockfile
bundle-2.3 exec rake gitlab:assets:compile RAILS_ENV=production NODE_ENV=production
bundle-2.3 exec rake gettext:compile RAILS_ENV=production
# After building assets, clean this up again
rm config/database.yml config/database.yml.postgresql.orig
mv config/resque.yml.patched config/resque.yml
-
- #put back the custom .yml
- mv config/gitlab.yml.bak config/gitlab.yml
}
package() {
@@ -159,6 +138,13 @@ package() {
install -d "${pkgdir}/usr/share/webapps"
cp -r "${srcdir}/${_srcdir}"* "${pkgdir}${_datadir}"
+ # Remove unneeded directories: node_modules is only needed during build
+ rm -r "${pkgdir}${_datadir}/node_modules"
+ # https://gitlab.com/gitlab-org/omnibus-gitlab/blob/194cf8f12e51c26980c09de6388bbd08409e1209/config/software/gitlab-rails.rb#L179
+ for dir in spec qa rubocop app/assets vendor/assets; do
+ rm -r "${pkgdir}${_datadir}/${dir}"
+ done
+
chown -R root:root "${pkgdir}${_datadir}"
chmod 755 "${pkgdir}${_datadir}"
@@ -166,7 +152,7 @@ package() {
install -dm750 -o 105 -g 105 "${pkgdir}${_homedir}/satellites"
install -dm750 -o 105 -g 105 "${pkgdir}${_homedir}/shared/"{,artifacts,lfs-objects}
install -dm750 -o 105 -g 105 "${pkgdir}${_homedir}/builds"
- install -dm750 -o 105 -g 105 "${pkgdir}${_homedir}/uploads"
+ install -dm700 -o 105 -g 105 "${pkgdir}${_homedir}/uploads"
install -dm750 -o 105 -g 105 "${pkgdir}${_homedir}/backups"
install -dm750 -o 105 -g 105 "${pkgdir}${_etcdir}"
install -dm755 "${pkgdir}/usr/share/doc/${_pkgname}"
@@ -202,7 +188,6 @@ package() {
# Install config files
for config_file in application.rb gitlab.yml unicorn.rb resque.yml; do
mv "config/${config_file}" "${pkgdir}${_etcdir}/"
- chown 105:105 "${pkgdir}${_etcdir}/${config_file}"
[[ -f "${pkgdir}${_datadir}/config/${config_file}" ]] && rm "${pkgdir}${_datadir}/config/${config_file}"
ln -fs "${_etcdir}/${config_file}" "${pkgdir}${_datadir}/config/"
done
@@ -231,14 +216,6 @@ package() {
install -Dm644 "${srcdir}/gitlab.tmpfiles.d" "${pkgdir}/usr/lib/tmpfiles.d/gitlab.conf"
install -Dm644 "${srcdir}/gitlab.logrotate" "${pkgdir}/etc/logrotate.d/gitlab"
-
- # Install webserver config templates
- for config_file in apache apache-ssl apache2.2 apache2.2-ssl nginx nginx-ssl lighttpd; do
- install -m644 "${srcdir}/${config_file}.conf.example" "${pkgdir}/usr/share/doc/${_pkgname}"
- done
-
- # Fix FS#58292
- chmod 644 "${pkgdir}"/usr/share/webapps/gitlab/vendor/bundle/ruby/2.3.0/gems/omniauth-jwt-0.0.2/lib/omniauth/strategies/jwt.rb
}
# vim:set ts=2 sw=2 et: