summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWorty2020-08-25 16:11:49 +0200
committerWorty2020-08-25 16:11:49 +0200
commit4067d41dcded1513c0272c74a22fd961ceceffa0 (patch)
tree1bed6ef00f5dc842be5cbd2a87d17a3811c6f41d /PKGBUILD
parent1758fef9e8dfc8618a7fd23b5739e8a2426c4d47 (diff)
downloadaur-4067d41dcded1513c0272c74a22fd961ceceffa0.tar.gz
v 1.10.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b29537a52544..1d78908afe62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=gitlab-glab
_realpkgname=glab
-pkgver=1.9.1
+pkgver=1.10.0
pkgrel=2
pkgdesc='GLab is an open source Gitlab Cli tool written in Go to help work seamlessly with Gitlab from the command line.'
arch=('x86_64')
@@ -11,7 +11,7 @@ license=('MIT')
makedepends=('go')
depends=('glibc')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('4df30e9570308019f633d14f69ba78b295a9b15f54ad1c5c8786cbb018bb1a01')
+sha256sums=('1051df68c2249bb88754324ee2ac549924c1b847fab13d20f2cecc8c61195586')
prepare(){
cd "${_realpkgname}-${pkgver}"
@@ -26,7 +26,7 @@ build() {
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
_builddate=$(date -u +%m/%d/%Y)
- go build -o build -trimpath -buildmode=pie -ldflags "-extldflags \"${LDFLAGS}\" -X main.version=v${pkgver} -X main.build=${_builddate} -s -w" -modcacherw ./cmd/glab/main.go
+ go build -o build -trimpath -buildmode=pie -ldflags "-extldflags \"${LDFLAGS}\" -X main.version=v${pkgver} -X main.build=${_builddate} -X main.usageMode=prod -s -w" -modcacherw ./cmd/glab/main.go
}
package() {