summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWorty2021-01-27 08:49:47 +0100
committerWorty2021-01-27 08:49:47 +0100
commit6ea0abd2e67e5f5934d4b1eed92ef99eb08c08b3 (patch)
treed9e39e407c39e9c55d3205049f1c1aae44311803 /PKGBUILD
parent4205bc23c4f93316b5ef5cf023f9079e9471916e (diff)
downloadaur-6ea0abd2e67e5f5934d4b1eed92ef99eb08c08b3.tar.gz
add FULL RELRO
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4581dad4cec5..7f6b4a357369 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=gitlab-glab
_realpkgname=glab
pkgver=1.14.0
-pkgrel=1
+pkgrel=2
pkgdesc='Gitlab Cli tool written in Go to help work seamlessly with Gitlab from the command line.'
arch=('x86_64')
url="https://github.com/profclems/glab"
@@ -26,7 +26,7 @@ build() {
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
_builddate=$(date -u +%m/%d/%Y)
- go build -o build -trimpath -buildmode=pie -ldflags "-extldflags \"${LDFLAGS}\" -X main.version=v${pkgver} -X main.build=${_builddate} -X main.usageMode=prod -s -w" -modcacherw ./cmd/glab/main.go
+ go build -o build -trimpath -buildmode=pie -ldflags "-linkmode=external -extldflags \"${LDFLAGS}\" -X main.version=v${pkgver} -X main.build=${_builddate} -X main.usageMode=prod -s -w" -modcacherw ./cmd/glab/main.go
}
package() {