summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKr1ss2021-09-04 15:15:09 +0200
committerKr1ss2021-09-04 15:15:09 +0200
commit1305c614e8a0167c0e897a1fd999855ddab97554 (patch)
tree22fb3cd54fd27165d7668da3ab1577fa2425b961 /PKGBUILD
parentde8916e1b0acdd17eb1e156604241f51de9e1e2e (diff)
downloadaur-1305c614e8a0167c0e897a1fd999855ddab97554.tar.gz
update: gitleaks 7.6.0-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index da95295cc230..058c560fa0c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Daniel M. Capella <polycitizen@gmail.com>
pkgname=gitleaks
-pkgver=7.5.0
+pkgver=7.6.0
pkgrel=1
pkgdesc='Audit Git repos for secrets and keys'
url=https://github.com/zricethezav/gitleaks
@@ -11,22 +11,23 @@ license=('MIT')
depends=('glibc')
makedepends=('go')
source=("$url/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
-sha256sums=('9b06dbec9d1bc220630bb85298158d8a54d4be6f068472a0b3a0cc7a89cdfec7')
+sha256sums=('922af2a6f3945954aacdf61919508d360685ee6fa165eab5070009ca9dcd523f')
build() {
cd "$pkgname-$pkgver"
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
- export CGO_LDFLAGS="${LDFLAGS}"
export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
- go build .
+ go build -ldflags "-X=github.com/zricethezav/gitleaks/v${pkgver%%.*}/version.Version=$pkgver -extldflags \"$LDFLAGS\"" .
}
package() {
cd "$pkgname-$pkgver"
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
- install -Dm755 "$pkgname" "$pkgdir"/usr/bin/"$pkgname"
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+ install -Dm644 README.md "$pkgdir"/usr/share/doc/"$pkgname"/README.md
+ install -Dm644 examples/* -t"$pkgdir"/usr/share/doc/"$pkgname"/examples/
+ install -Dm755 "$pkgname" "$pkgdir"/usr/bin/"$pkgname"
}
# vim:set ts=2 sw=2 et: