summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorimlonghao2020-02-07 13:21:50 +0000
committerimlonghao2020-02-07 13:21:50 +0000
commitb3cfd7a08cd852859f223c208e5ddd32e4cd1afe (patch)
treef0ace83c672bdef2f4b25fde4b09a735717b064f /PKGBUILD
parent1687e3d202078f6f408bd0e24666c0448415ebcf (diff)
downloadaur-b3cfd7a08cd852859f223c208e5ddd32e4cd1afe.tar.gz
New version 3.3.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 11 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 85cd123cb8b8..d3fb531257ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,27 @@
-# Maintainer: Daniel M. Capella <polycitizen@gmail.com>
+# Maintainer: Hao Long <aur@esd.cc>
+# Contributor: Daniel M. Capella <polycitizen@gmail.com>
pkgname=gitleaks
-pkgver=1.20.0
+pkgver=3.3.0
pkgrel=1
pkgdesc='Audit Git repos for secrets and keys'
url=https://github.com/zricethezav/gitleaks
-arch=('x86_64')
-license=('GPL3')
+arch=('x86_64' 'i686')
+license=('MIT')
depends=('glibc')
makedepends=('go-pie')
source=("$url/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
-sha512sums=('9a4793e9f1f24e5d553f4253b7de1096345685bdeb5bfdf22836e48dbb3c22291b7d2b4a4be833b42afe1bd9870452776c873f626ce18bdb6ea0e927631c1028')
-
-prepare() {
- mkdir -p src/github.com/zricethezav
- ln -rsnf gitleaks-$pkgver src/${url#*//}
-}
+sha256sums=('03f3484bc781a6d63486e763f30be421a313893c78b6f84137ea05319cda8c96')
build() {
- cd src/${url#*//}
- export GOPATH="$srcdir"
- go build -v
+ cd "$pkgname-$pkgver"
+ go build
}
package() {
- cd gitleaks-$pkgver
- install -Dt "$pkgdir"/usr/bin gitleaks
+ cd "$pkgname-$pkgver"
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+ install -Dm755 "$pkgname" "$pkgdir"/usr/bin/"$pkgname"
}
# vim:set ts=2 sw=2 et: