summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorimlonghao2020-08-13 14:28:14 +0000
committerimlonghao2020-08-13 14:28:14 +0000
commitb920bc342b49e345f0add0c4fb4aee28d6081e91 (patch)
tree900aa6fdca218cfbc053af78bbffe7b156453524 /PKGBUILD
parent7a02f9305f5cb30c6c102ec4889d23d280606cd7 (diff)
downloadaur-b920bc342b49e345f0add0c4fb4aee28d6081e91.tar.gz
New version 6.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 901a344e99b7..e3d3ad848e85 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Daniel M. Capella <polycitizen@gmail.com>
pkgname=gitleaks
-pkgver=5.0.1
+pkgver=6.0.0
pkgrel=1
pkgdesc='Audit Git repos for secrets and keys'
url=https://github.com/zricethezav/gitleaks
@@ -11,17 +11,16 @@ license=('MIT')
depends=('glibc')
makedepends=('go')
source=("$url/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
-sha256sums=('ead9bdbf0205bb5d3d1c0c14cafcc1ed72a1ee7c0f9d26b3f7efb1f956fd242a')
+sha256sums=('0e0c3c0f73c3fa78e1ca924ff69b1df7b85dc180d4672d27da0c8d1c910f5d0e')
build() {
cd "$pkgname-$pkgver"
- go build \
- -trimpath \
- -buildmode=pie \
- -mod=readonly \
- -modcacherw \
- -ldflags "-extldflags \"${LDFLAGS}\"" \
- .
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build .
}
package() {