summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkpcyrd2021-09-20 01:46:25 +0200
committerkpcyrd2021-09-20 01:46:25 +0200
commitedde7b60f5efb998a00a845c57ea9495bdd3ed78 (patch)
tree7dc5ac1acbcf84c8a1749db73e3e4373cd3088a8 /PKGBUILD
downloadaur-edde7b60f5efb998a00a845c57ea9495bdd3ed78.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7df23853a1d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: kpcyrd <git@rxv.cc>
+
+_gitname=gitoops
+pkgname=gitoops-git
+pkgver=0.0.0.r33
+pkgrel=1
+pkgdesc="Identify lateral movement and privilege escalation paths in CI/CD environments"
+url="https://github.com/ovotech/gitoops"
+makedepends=('go')
+provides=('gitoops')
+conflicts=('gitoops')
+arch=('i686' 'x86_64' 'armv6h' 'aarch64')
+license=('MIT')
+source=("git+https://github.com/ovotech/${_gitname}.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${_gitname}"
+ echo 0.0.0.r$(git rev-list HEAD --count)
+}
+
+build() {
+ cd "${_gitname}"
+ go build -o gitoops ./cmd/
+}
+
+package() {
+ cd "${_gitname}"
+ install -Dm755 gitoops -t "${pkgdir}/usr/bin"
+ install -Dm644 README.md docs/* \
+ -t "${pkgdir}/usr/share/doc"
+}
+
+# vim:set ts=2 sw=2 et: