summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrian Bidulock2015-01-09 04:22:56 -0700
committerBrian Bidulock2015-06-10 05:44:00 -0600
commit1d1951da2a0f4edc1aecbf4794133f876a6c2741 (patch)
tree608217cb587df6adac9bb30fad13ef27592643c1 /PKGBUILD
parent318f459387c61e458989e4a74f8480d81067c9e8 (diff)
downloadaur-1d1951da2a0f4edc1aecbf4794133f876a6c2741.tar.gz
version 0.7.9-3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 11 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 932cfd52d31a..ada1521d64a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,32 +2,29 @@
pkgname=gjdoc
pkgver=0.7.9
-pkgrel=2
+pkgrel=3
pkgdesc="GNU Classpath JavaDoc implementation"
arch=(i686 x86_64)
license=('GPL')
url="http://savannah.gnu.org/projects/classpath/"
-depends=('gcc-gcj>=4.3.1')
-options=('!libtool')
-noextract=('antlr-2.7.5.jar')
+depends=('gcc-gcj>=4.9.2')
+options=('!libtool' '!buildflags')
+noextract=('antlr-2.7.7.jar')
source=(http://ftp.gnu.org/gnu/classpath/${pkgname}-${pkgver}.tar.gz
- http://www.antlr2.org/download/antlr-2.7.5.jar)
+ http://www.antlr2.org/download/antlr-2.7.7.jar)
md5sums=('24cade2efe22d5adefcbabb21f094803'
- '6d57df718efd2a03981c309ce3330a1f')
+ 'f8f1352c52a4c6a500b597596501fc64')
build() {
- export -n CFLAGS
- export -n CXXFLAGS
- export -n LDFLAGS
- cd ${srcdir}/${pkgname}-${pkgver}
- ./configure --prefix=/usr --with-antlr-jar=${srcdir}/antlr-2.7.5.jar || return 1
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr --with-antlr-jar=${srcdir}/antlr-2.7.7.jar
make || find . -type f -name '*.o' | while read f; do objcopy -L '_ZGr8_$_dummy' $f; done
make || find . -type f -name '*.o' | while read f; do objcopy -L '_ZGr8_$_dummy' $f; done
make || find . -type f -name '*.o' | while read f; do objcopy -L '_ZGr8_$_dummy' $f; done
make || find . -type f -name '*.o' | while read f; do objcopy -L '_ZGr8_$_dummy' $f; done
- make || return 1
+ make GCJFLAGS='-g -O2 -fsource=1.3'
}
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
- make DESTDIR=${pkgdir} install || return 1
+ cd $pkgname-$pkgver
+ make DESTDIR=${pkgdir} install
}