summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRobin Thompson2016-12-29 10:07:48 +0000
committerRobin Thompson2016-12-29 10:07:48 +0000
commit75c05ba81d18bbcbd8354065de102b070c64c9a8 (patch)
tree4c280357fb8314e1ece6dbc6d79b854c5bc1731a /PKGBUILD
downloadaur-75c05ba81d18bbcbd8354065de102b070c64c9a8.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..00c3dde8126e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Robin Thompson <robin*dot*thompson99*at*gmail*dot*com>
+_pkgname=gladrags
+pkgname=gladrags-git
+pkgver=0.22.r0.gc44c89f
+pkgrel=1
+epoch=
+pkgdesc="An applet to smarten up MATE panels"
+arch=('any')
+url="https://github.com/robint99/gladrags"
+license=('GPLv3')
+depends=("mate-panel" "python" "python-gobject" "imagemagick")
+makedepends=("git")
+install="gladrags.install"
+source=("git+http://github.com/robint99/gladrags")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --long --tags | sed 's/^V//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/gladrags"
+ aclocal
+ automake --add-missing
+ autoreconf
+ ./configure --prefix=/usr --disable-schemas-compile
+ make
+}
+
+package() {
+ cd "$srcdir/gladrags"
+ make DESTDIR="$pkgdir/" install
+}