summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVolker Schatz2019-01-17 17:34:32 +0100
committerVolker Schatz2019-01-17 17:34:32 +0100
commitfa7dad66e924a94ae64d9c98dc94c17cc68c3714 (patch)
tree932c7d1e80d6a72f072feb69c42fb90bb1d65049 /PKGBUILD
downloadaur-fa7dad66e924a94ae64d9c98dc94c17cc68c3714.tar.gz
Initial PKGBUILD of the Python reimplementation of gladtex
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b9ef1278b0a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Volker Schatz <arch@my-name-without-hyphen.com>
+pkgname=gladtex2
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="A utility for writing LaTeX equations within HTML - Python rewrite"
+depends=('python>=3.4' 'texlive-bin' 'texlive-latexextra')
+makedepends=('pandoc')
+conflicts=('gladtex')
+arch=('i686' 'x86_64')
+license=('LGPL')
+url="https://humenda.github.io/GladTeX/"
+source=( "https://github.com/humenda/GladTeX/archive/v3.0.0.tar.gz" )
+sha256sums=('319b5f1741f6635f0cc542527626def47578989af84d3fbce1413d24cefc89ce')
+
+build() {
+ cd "$srcdir/GladTeX-$pkgver"
+ python ./setup.py build
+}
+
+package() {
+ cd "$srcdir/GladTeX-$pkgver"
+ python ./setup.py install --prefix=/usr --root="$pkgdir"
+ install -m 644 -D build/gladtex.1 "$pkgdir"/usr/man/man1/gladtex.1
+}
+
+# vim: set ts=2 sw=2 et: