summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMagnus Boman2021-03-10 20:12:11 +0100
committerMagnus Boman2021-03-10 20:12:11 +0100
commit611ca948db940531b284872b6258cee3a217c8b8 (patch)
treefc855960b44c2fd1f7a8b32b25c4a11e7b86a659 /PKGBUILD
parentbb8af4ee0c4cb157ac026f0fb4814f7fc39e7f3d (diff)
downloadaur-611ca948db940531b284872b6258cee3a217c8b8.tar.gz
upgpkg: glances-git 3.1.6.1.r30.gd201e647-1
conform to packaging standards
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5dc63cd96d82..ab44e61b15f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Francois Boulogne <fboulogne at april dot org>
pkgname=glances-git
-pkgver=3.1.4.r39.g9f8a8120
+pkgver=3.1.6.1.r30.gd201e647
pkgrel=1
pkgdesc='CLI curses-based monitoring tool'
arch=(any)
@@ -27,12 +27,16 @@ sha512sums=('SKIP'
'49f0d185a37a5c5837e5beb463770c943ede40b2f1b8405e338129e897e97d9fc58373a8586fabc506266e6343cfea3c91b9787ac6832cc97a1ab63d6ad058d4')
pkgver() {
+ git -C "${pkgname%-git}" describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
cd "${pkgname%-git}"
- git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ python setup.py build
}
package() {
cd "${pkgname%-git}"
- python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 --skip-build
install -Dm644 "${srcdir}"/glances.service -t "${pkgdir}"/usr/lib/systemd/system
}