summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMagnus Boman2022-03-24 17:44:18 +0100
committerMagnus Boman2022-03-24 17:44:18 +0100
commitc02dcd62083791dd5a50d1b8164570edfde4f566 (patch)
tree75d42af81e6a000542734fef01fd062971a9efd9 /PKGBUILD
parentf5d2a20c57a9fa308f446890875424900d5c6f61 (diff)
downloadaur-c02dcd62083791dd5a50d1b8164570edfde4f566.tar.gz
upgpkg: glances-git 3.2.4.2.r65.g021ac4ce-1
Switch to PEP517
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index feddd747aca2..6365e9a63983 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,13 @@
# Contributor: Francois Boulogne <fboulogne at april dot org>
pkgname=glances-git
-pkgver=3.2.2.r11.gbdeb414a
+pkgver=3.2.4.2.r65.g021ac4ce
pkgrel=1
pkgdesc='CLI curses-based monitoring tool (git)'
arch=(any)
url=https://github.com/nicolargo/glances
license=(LGPL)
-makedepends=(git python-setuptools)
+makedepends=(python-build python-installer python-setuptools python-wheel git)
depends=(python python-psutil python-future python-defusedxml)
optdepends=('hddtemp: HDD temperature monitoring support'
'python-bottle: web server support'
@@ -33,11 +33,11 @@ pkgver() {
build() {
cd "${pkgname%-git}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${pkgname%-git}"
- python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 "${srcdir}"/glances.service -t "${pkgdir}"/usr/lib/systemd/system
}