summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2017-08-08 12:48:51 +0430
committerMohammadreza Abdollahzadeh2017-08-08 12:48:51 +0430
commitd94dc5df54618381fbddf5da173bb5f688e89847 (patch)
treea749893214e0d96361c26c9730986ae18c7ab421 /PKGBUILD
downloadaur-d94dc5df54618381fbddf5da173bb5f688e89847.tar.gz
initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d55c33bc6bc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+
+pkgname=glassfish5
+pkgver=5.0_b18_08_07_2017
+_oraver=5.0-b18-08_07_2017
+pkgrel=1
+pkgdesc="The Open Source Java EE 8 Reference Implementation."
+url="https://javaee.github.io/glassfish/"
+license=("CDDL")
+provides=("glassfish5")
+conflicts=("glassfish5")
+depends=("java-environment>=8")
+arch=("any")
+options=(!strip)
+source=("http://download.oracle.com/glassfish/${pkgver}/nightly/glassfish-${_oraver}.zip"
+ "glassfish5.service")
+
+sha256sums=('790b3395da69934059b3e099993dfd92e4e7381437edec715221109de1c93233'
+ '9be6b53df62a719e4cac1b54703f0abcc6c22389d1b46e3e85ed38d6f1453cdc')
+
+package() {
+ install -d $pkgdir/opt
+ cp -a glassfish5 $pkgdir/opt/glassfish5
+ install -D glassfish5.service $pkgdir/usr/lib/systemd/system/glassfish5.service
+}