summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGlaxnimate CI2022-09-11 10:58:20 +0000
committerGlaxnimate CI2022-09-11 10:58:20 +0000
commit4d5ae34b56f9161a05f8b0f9775c6e707d7bd79f (patch)
tree6a8e8617fa0c7924f0a92813c633f6c6ed2315a6 /PKGBUILD
parent8a70e871fb6c1a1e5e789e869ab70994caecc07e (diff)
downloadaur-4d5ae34b56f9161a05f8b0f9775c6e707d7bd79f.tar.gz
Update to version 0.5.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f6ca61524cbd..a20df34785cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,20 @@
# Maintainer: Mattia Basaglia <glax@dragon.best>
_corpname=glaxnimate
_pkgname='glaxnimate'
-pkgname="$_pkgname"
-pkgver=0.5.0_1_g49002eec
+pkgname="glaxnimate"
+_git_branch=release
+pkgver=0.5.0_155_g91219dc5
pkgrel=1
pkgdesc="Simple vector animation program."
url="https://glaxnimate.mattbas.org/"
license=('GPL3')
arch=('x86_64' 'i686' 'armv7h' 'aarch64' 'riscv32' 'riscv64')
-makedepends=('git' 'cmake' 'qt5-tools')
-depends=('python' 'zlib' 'hicolor-icon-theme' 'qt5-base' 'potrace' 'ffmpeg' 'qt5-imageformats' 'qt5-svg' 'libarchive')
+makedepends=('git' 'cmake' 'make' 'gcc' 'qt6-declarative')
+depends=('python' 'zlib' 'hicolor-icon-theme' 'potrace' 'ffmpeg' 'libarchive' 'qt6-tools' 'qt6-base' 'qt6-imageformats' 'qt6-svg')
provides=("$_pkgname")
conflicts=("$_pkgname")
source=(
- "$_pkgname::git+https://gitlab.com/mattbas/$_pkgname/#branch=release"
+ "$_pkgname::git+https://gitlab.com/mattbas/$_pkgname/#branch=$_git_branch"
)
sha256sums=('SKIP')
@@ -40,10 +41,11 @@ build() {
# echo 'MAKEFLAGS="-j4"' >>/etc/makepkg.conf
# (or ~/.makepkg.conf)
make
- make translations
+ make translations VERBOSE=1
}
package() {
cd "$srcdir/$_pkgname/build"
make install DESTDIR=$pkgdir >/dev/null
}
+