summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnton Leontiev2016-08-24 06:11:23 +0300
committerAnton Leontiev2016-08-24 06:11:23 +0300
commita560798977e8608fb467f92bb097fa59241d4fb7 (patch)
tree859546f2dfce48dbad3338866dcce134784c9649 /PKGBUILD
parent782be49792bb40f97f7214a8fabe9790e9850c99 (diff)
downloadaur-gle-graphics.tar.gz
Update to v4.2.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD66
1 files changed, 29 insertions, 37 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8964428bfaba..945e288ff80b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,43 @@
-# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
+# Contributor: Anton Leontiev <scileont /at/ gmail.com>
# Contributor: B. Lee <darklin20 /at/ gmail.com>
+# Contributor: jerry73204 <jerry73204 /at/ gmail.com>
pkgname=gle-graphics
-pkgver=4.2.4c
-pkgrel=3
-arch=('i686' 'x86_64')
+pkgver=4.2.5
+pkgrel=1
+arch=('i686' 'x86_64' 'armv7h')
pkgdesc='Graphics scripting language for creating graphs, plots, diagrams and figures'
url='http://www.gle-graphics.org/'
license=('BSD' 'GPL')
-depends=('libtiff' 'libjpeg' 'libpng15' 'ghostscript')
-makedepends=('qt4' 'openssl' 'zlib' 'ghostscript' 'texlive-bin' 'texlive-core' 'texlive-latexextra')
-optdepends=('texlive: latex labels in gle scripts' 'qt4: qgle')
-source=(http://prdownloads.sourceforge.net/glx/gle-graphics-${pkgver}f-src.tar.gz
- gle-graphics-$pkgver-libloader.patch
- gle-graphics-$pkgver-transperancy.patch
- gle-graphics-$pkgver-non-ascii.patch)
-install=gle-graphics.install
-md5sums=('5eef0a63ee0077237b8a36fe1a24407f'
- '92f81bd634975bb96154ebfc2337629e'
- 'cecfbdf3d18390485a8a963448fd55aa'
- '2196ee0a27645b764ac84f59957c79f3')
-
-# I didn't split building into build() and package() because it works
-# incorrectly with gle-graphics. And I don't know why!!
+depends=('libtiff' 'libjpeg' 'ghostscript' 'poppler-glib')
+makedepends=('qt4' 'openssl' 'zlib' 'ghostscript' 'texlive-bin' 'texlive-core' 'texlive-latexextra')
+optdepends=('texlive: latex labels in GLE scripts' 'qt4: qgle')
+source=(http://prdownloads.sourceforge.net/glx/gle-graphics-${pkgver}f-src.tar.gz)
+md5sums=('c28c17aa8448822667604631ec7c8629')
-build() {
- cd $srcdir/$pkgname-$pkgver
+prepare() {
+ cd $pkgname-$pkgver
- unset MAKEFLAGS
- sed -i -e 's:GLE_INSTALL_DATA=$prefix/share/$PACKAGE_TARNAME/$GLE_VERSION:GLE_INSTALL_DATA=$prefix/share/$PACKAGE_TARNAME:' configure
+ #sed -i -e 's:GLE_INSTALL_DATA=$prefix/share/$PACKAGE_TARNAME/$GLE_VERSION:GLE_INSTALL_DATA=$prefix/share/$PACKAGE_TARNAME:' configure
+}
-# patch -p1 -i $srcdir/gle-graphics-$pkgver-libloader.patch
- patch -p1 -i $srcdir/gle-graphics-$pkgver-transperancy.patch
- patch -p1 -i $srcdir/gle-graphics-$pkgver-non-ascii.patch
+build() {
+ cd $pkgname-$pkgver
- ./configure --prefix=/usr --with-qt --with-jpeg --with-png --with-tiff --with-z \
- --with-manip --with-libgle --with-rpath=no --with-extrafonts --with-x
+ CPPFLAGS+=' -O2' ./configure --prefix=/usr --with-qt --with-jpeg \
+ --with-png --with-tiff --with-z --with-manip --with-libgle \
+ --with-rpath=no --with-extrafonts --with-x
- make
+ make -j1
+ make -j1 doc
+}
- # Add just compiled GLE to path in order to build documentation
- set PATH=$PATH:$srcdir/$pkgname-$pkgver/build/bin
- make doc
+package() {
+ cd $pkgname-$pkgver
- make DESTDIR=$pkgdir install
+ make -j1 DESTDIR="$pkgdir" install
- install -D -m644 LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
- install -D -m644 platform/autopackage/gle.png $pkgdir/usr/share/icons/hicolor/48x48/apps/gle.png
- install -D -m644 platform/autopackage/gle.xml $pkgdir/usr/share/mime/packages/gle.xml
- install -D -m644 platform/autopackage/gle.desktop $pkgdir/usr/share/applications/gle.desktop
+ install -D -m644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D -m644 platform/autopackage/gle.png "$pkgdir/usr/share/icons/hicolor/48x48/apps/gle.png"
+ install -D -m644 platform/autopackage/gle.xml "$pkgdir/usr/share/mime/packages/gle.xml"
+ install -D -m644 platform/autopackage/gle.desktop "$pkgdir/usr/share/applications/gle.desktop"
}