summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMike Sampson2015-06-21 20:10:26 +1000
committerMike Sampson2015-06-21 20:10:26 +1000
commitef4adf9c90b5039bbe0d34e41ed056d50cb37fdd (patch)
tree780b2859637a2dfeb83f866b87bfa1e0d2346c6d /PKGBUILD
downloadaur-gle-te.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1148e66369d3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Mike Sampson <mike at sambodata dot com>
+# Contributor: Lawrence Lee <valheru at facticius dot net>
+pkgname=gle-te
+pkgver=3.1.0
+pkgrel=1
+pkgdesc="a library of C functions that draw extruded surfaces, including surfaces of revolution, sweeps, tubes, polycones, polycylinders and helicoids."
+arch=('i686' 'x86_64')
+url="http://www.linas.org/gle/index.html"
+license=('GPL')
+depends=('libgl')
+makedepends=('gcc' 'glut')
+source=(http://downloads.sourceforge.net/gle/gle-$pkgver.tar.gz)
+md5sums=('da5b45c6906343d4a3672c3de35513ad')
+options=(!libtool)
+
+build() {
+ cd "$srcdir/gle-$pkgver"
+
+ ./configure --prefix=/usr --mandir=/usr/share
+ make
+}
+
+package() {
+ cd "$srcdir/gle-$pkgver"
+
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: