summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLubosz Sarnecki2015-06-22 22:55:28 +0200
committerLubosz Sarnecki2015-06-22 22:55:28 +0200
commite815c8d162a9e0d47e49915a4e77e57104ab5a64 (patch)
treed5f1b84756a06d6e80b8ef2fe72550b335d28b03 /PKGBUILD
downloadaur-gletools-hg.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..55a60a65f03c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Lubosz Sarnecki <lubosz at gmail com>
+
+pkgname=gletools-hg
+pkgver=20101219
+pkgrel=1
+pkgdesc="Advanced opengl utilities for pyglet."
+arch=(any)
+url="http://codeflow.org"
+license=('custom:AGPL3')
+depends=('python2' 'pyglet-hg')
+makedepends=('python2-distribute' 'mercurial')
+conflicts=('gletools')
+provides=('gletools')
+source=()
+md5sums=()
+
+_hgbranch=http://hg.codeflow.org/gletools
+_hgrepo=gletools
+
+build() {
+ cd ${srcdir}
+
+ if [ -d ${_hgrepo} ]; then
+ (cd ${_hgrepo} && hg pull -u) || return 1
+ else
+ hg clone ${_hgbranch} || return 1
+ fi
+
+ msg "Mercurial clone done or server timeout"
+
+ cd ${_hgrepo}
+
+ python2 setup.py build || return 1
+ python2 setup.py install --root=$pkgdir --optimize=1 || return 1
+}