summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbartus2016-11-28 20:59:52 +0100
committerbartus2016-11-28 20:59:52 +0100
commit27d53693e89b980d3686ff6c4827056de4ba6229 (patch)
tree6b9bd989ac477c8a267a0e20715e88575bc755cb /PKGBUILD
downloadaur-27d53693e89b980d3686ff6c4827056de4ba6229.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c668c14797f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: bartus <aur@bartus.33mail.com>
+
+_pkgname=glew
+pkgver=1.13.0
+pkgname=glew-${pkgver}
+pkgrel=1
+pkgdesc="The OpenGL Extension Wrangler Library"
+arch=('i686' 'x86_64')
+url="http://glew.sourceforge.net"
+license=('BSD' 'MIT' 'GPL')
+depends=('libxmu' 'libxi' 'glu')
+source=(http://downloads.sourceforge.net/${_pkgname}/${_pkgname}-${pkgver}.tgz)
+sha1sums=('d5b1c499f429aa91c466193b4e8ea94a84019e37')
+
+build() {
+ cd ${_pkgname}-${pkgver}
+
+ # move include folder to subfolder 'glew-1.13.0'
+ sed -i 's:$(GLEW_DEST)/include/GL:$(GLEW_DEST)/include/glew-1.13.0/GL:' Makefile
+
+ sed -i 's|lib64|lib|' config/Makefile.linux
+ sed -i '/^.PHONY: .*\.pc$/d' Makefile
+ make
+}
+
+package() {
+ cd ${_pkgname}-${pkgver}
+ # update glewmx include path to reflect previous changes (see build comments)
+ msg update glewmx.pc
+ sed -i 's:includedir=${prefix}/include:includedir=${prefix}/include/glew-1.13.0:' glewmx.pc
+ # install only mx library
+ make GLEW_DEST="${pkgdir}/usr" install.mx
+}