summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEmmanuel Gil Peyrot2020-08-11 19:52:14 +0200
committerEmmanuel Gil Peyrot2020-08-11 19:52:14 +0200
commit904d8e412e94ce56e1093f053f993e41e6ba3e7b (patch)
tree9db42320de2ac8f4620aee6afb949fe7ad891340 /PKGBUILD
downloadaur-904d8e412e94ce56e1093f053f993e41e6ba3e7b.tar.gz
Hello world!
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd19442bcb13
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
+
+pkgname=glfw2to3-git
+pkgver=2.7.10
+pkgrel=1
+pkgdesc="Porting library to make GLFW 2.x games run on top of GLFW 3.x"
+arch=('x86_64')
+url="https://www.glfw.org/"
+license=('ZLIB')
+depends=('glfw')
+makedepends=('git' 'meson')
+provides=('glfw2to3' 'glfw2=2.7.10')
+conflicts=('glfw2to3' 'glfw2')
+source=("git+https://github.com/linkmauve/glfw2to3")
+sha256sums=('SKIP')
+
+prepare() {
+ cd glfw2to3
+}
+
+build() {
+ cd glfw2to3
+ arch-meson build
+ ninja -C build
+}
+
+package() {
+ cd glfw2to3
+ DESTDIR="$pkgdir"/ ninja -C build install
+
+ # This would conflict with glfw3.
+ rm "$pkgdir"/usr/lib/libglfw.so
+}