summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSolomon Choina2023-10-16 08:50:51 -0400
committerSolomon Choina2023-10-16 08:50:51 -0400
commit9a981c1e2480ef3e0e2eea13de62e3fc6e5041b0 (patch)
treeb56a8e89e852cf7690b7aaab8cf822a753da53b8 /PKGBUILD
parentf23b1086d8cfa7669442ccf7f04032258b5fbf7a (diff)
downloadaur-glib2-git.tar.gz
updpkgver and fix stuff
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 37 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 469fbdb5156b..d37605cc8002 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,17 +5,17 @@
pkgbase=glib2-git
_pkgname=glib2
pkgname=(glib2-git glib2-docs-git)
-pkgver=2.74.0.319.g9635fd4e4
+pkgver=2.78.0.r212.g0a6e19f
pkgrel=1
pkgdesc="Low Level Core Library"
arch=('x86_64')
url="https://wiki.gnome.org/Projects/GLib"
license=(LGPL2.1)
depends=(
- pcre libffi libutil-linux zlib
+ pcre libffi util-linux-libs zlib libsysprof-capture
)
makedepends=(
- gettext gtk-doc shared-mime-info python libelf git util-linux meson dbus
+ gettext gtk-doc shared-mime-info python libelf git util-linux meson dbus gi-docgen
)
checkdepends=(
desktop-file-utils
@@ -26,19 +26,21 @@ optdepends=(
)
conflicts=($_pkgname)
provides=($_pkgname=$pkgver)
-options=(!emptydirs)
+options=(debug staticlibs)
source=("git+https://gitlab.gnome.org/GNOME/glib.git"
+ "git+https://gitlab.gnome.org/GNOME/gvdb.git"
0001-noisy-glib-compile-schemas.patch
glib-compile-schemas.hook
gio-querymodules.hook )
sha512sums=('SKIP'
+ 'SKIP'
'ddbf4a8eaf60e943a10a1ad67f2de078143558df8cc06e8009da87d8068af0cf8c66f443474b8b2848239c003e6210ff9ceb1ba5ffda1b95b80687adbf813722'
'c04fe25afc217c295b5ce4034733cec046126482d00fb8d0299e4815ac57129dd3f1c9ac824b9386d208a4f113e9dae682ea5b72f75387ed6b6b96a9cbbee8ca'
'5afd6f275c8fff16df3e685818f2e7989b39ffb3b8f5fc261a5a6d54a9b28ef53af62f3bf5067cf87cb74691572f85730cbc508691956ae048a0f3ecc1a0a39c')
pkgver() {
cd glib
- git describe --tags | sed 's/-/./g'
+ git describe --long --tags --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
@@ -46,16 +48,34 @@ prepare() {
# Suppress noise from glib-compile-schemas.hook
patch -Np1 -i ../0001-noisy-glib-compile-schemas.patch
+ git submodule init
+ git submodule set-url subprojects/gvdb "$srcdir/gvdb"
+ git -c protocol.file.allow=always submodule update
+
+
}
build () {
- CFLAGS+=" -DG_DISABLE_CAST_CHECKS"
- arch-meson glib build \
- -Dgtk_doc=true \
- -Dman=true \
- -Dselinux=disabled
+ local meson_options=(
+ --default-library both
+ -D glib_debug=disabled
+ -D gtk_doc=true
+ -D man=true
+ -D selinux=disabled
+ -D sysprof=enabled
+ )
+
+ # Produce more debug info: GLib has a lot of useful macros
+ CFLAGS+=" -g3"
+ CXXFLAGS+=" -g3"
+
+ # use fat LTO objects for static libraries
+ CFLAGS+=" -ffat-lto-objects"
+ CXXFLAGS+=" -ffat-lto-objects"
+
+ arch-meson glib build "${meson_options[@]}"
+ meson compile -C build
- ninja -C build
}
#check() {
@@ -65,6 +85,11 @@ build () {
package_glib2-git() {
provides+=(libgio-2.0.so libglib-2.0.so libgmodule-2.0.so libgobject-2.0.so
libgthread-2.0.so)
+ depends+=(
+ libffi.so
+ libmount.so
+ )
+
DESTDIR="$pkgdir" meson install -C build
@@ -73,7 +98,7 @@ package_glib2-git() {
install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 "$srcdir"/*.hook
python -m compileall -d /usr/share/glib-2.0/codegen "$pkgdir/usr/share/glib-2.0/codegen"
- python -O -m compileall -d /usr/share/glib-2.0/codegen "$pkgdir/usr/share/glib-2.0/codegen"
+ python -O -m compileall -d /usr/share/glib-2.0/codegen "$pkgdir/usr/share/glib-2.0/codegen"
}
package_glib2-docs-git() {