summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVaporeon2015-09-05 10:44:45 +1200
committerVaporeon2015-09-05 10:44:45 +1200
commitcc81779e8d95273fb08b4513da03548de863a496 (patch)
tree233fbf9b0c471e9aa3854417b0969017584d9f25 /PKGBUILD
downloadaur-cc81779e8d95273fb08b4513da03548de863a496.tar.gz
Initial Commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD56
1 files changed, 56 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..da88bdd76ae2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Vaporeon <vaporeon@tfwno.gf>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+
+pkgbase=glib2-patched-thumbnailer
+pkgname=glib2-patched-thumbnailer
+pkgver=2.44.1
+pkgrel=1
+pkgdesc="GLib2 patched with ahodesuka's thumbnailer patch."
+url="http://gist.github.com/ahodesuka/49c1d0eea4b64f24c4c7"
+arch=(i686 x86_64)
+provides=(glib2)
+conflicts=(glib2)
+makedepends=('pkg-config' 'python2' 'libxslt' 'docbook-xml' 'pcre' 'libffi' 'elfutils')
+depends=('pcre' 'libffi' 'tumbler')
+optdepends=('python2: for gdbus-codegen and gtester-report'
+ 'elfutils: gresource inspection tool')
+options=('!docs' '!emptydirs')
+license=('LGPL')
+source=(http://ftp.gnome.org/pub/GNOME/sources/glib/${pkgver:0:4}/glib-$pkgver.tar.xz
+ revert-warn-glib-compile-schemas.patch
+ https://gist.githubusercontent.com/ahodesuka/49c1d0eea4b64f24c4c7/raw/d0edf118e1c27700300038c1d82b3ff775c0216b/glib-thumbnailer.patch)
+sha256sums=('8811deacaf8a503d0a9b701777ea079ca6a4277be10e3d730d2112735d5eca07'
+ '049240975cd2f1c88fbe7deb28af14d4ec7d2640495f7ca8980d873bb710cc97'
+ '1a4673380fbdf8e8e5de3367089de6c97025633e54010575de63c5ab6c8a044d')
+
+prepare() {
+ cd glib-$pkgver
+ patch -Rp1 -i ../revert-warn-glib-compile-schemas.patch
+ patch -Np1 -i ${srcdir}/glib-thumbnailer.patch
+}
+
+build() {
+ cd glib-$pkgver
+ PYTHON=/usr/bin/python2 ./configure --prefix=/usr --libdir=/usr/lib \
+ --sysconfdir=/etc \
+ --with-pcre=system \
+ --disable-fam
+ make
+}
+
+check() {
+ cd glib-$pkgver
+ #make -k check || :
+}
+
+package() {
+ cd glib-$pkgver
+ make completiondir=/usr/share/bash-completion/completions DESTDIR="$pkgdir" install
+
+ for _i in "$pkgdir/usr/share/bash-completion/completions/"*; do
+ chmod -x "$_i"
+ done
+
+ # Our gdb does not ship the required python modules, so remove it
+ rm -rf "$pkgdir/usr/share/gdb/"
+}