summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEli Schwartz2021-01-14 20:13:20 -0500
committerEli Schwartz2021-01-14 20:26:59 -0500
commita71046c7e2e32e420e0f4f3794c5cf9a6157dabf (patch)
treefe54f80468a9c405fd595c18057a06e5c782b238 /PKGBUILD
parent35f1217a2c5677fed7d05339630acecdb9ed51c2 (diff)
downloadaur-a71046c7e2e32e420e0f4f3794c5cf9a6157dabf.tar.gz
upgpkg: glibc-git 2.32.r537.g2d651eb926-1
Remove workaround for electron 2.x and broken lld. Originally reported in mid-2018, this old version of electron is long since unsupported and most applications have surely moved onto electron 3+. sync optdepends with core/glibc
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 5 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1307110da03b..e673315cbbab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# All my PKGBUILDs are managed at https://github.com/eli-schwartz/pkgbuilds
pkgname=glibc-git
-pkgver=2.32.r69.g567b170501
+pkgver=2.32.r537.g2d651eb926
pkgrel=1
pkgdesc='GNU C Library'
arch=('i686' 'x86_64')
@@ -12,7 +12,8 @@ url='https://www.gnu.org/software/libc/'
license=('GPL' 'LGPL')
groups=('base')
depends=('linux-api-headers' 'tzdata' 'filesystem')
-optdepends=('gd: graph image generation with memusage')
+optdepends=('gd: graph image generation with memusage'
+ 'perl: for mtrace')
makedepends=('git' 'python')
# XXX Arch Linux's valgrind package requires an exact version
provides=("glibc=${pkgver%%.r*}")
@@ -21,11 +22,9 @@ backup=('etc/gai.conf' 'etc/nscd.conf')
options=('staticlibs')
install='glibc-git.install'
source=('git+https://sourceware.org/git/glibc.git'
- 'locale-gen'
- '0001-Revert-elf-Correct-absolute-SHN_ABS-symbol-run-time-.patch')
+ 'locale-gen')
sha256sums=('SKIP'
- '05fbb88877cdddc99ef25e48304d6e5ac236660c20925d461cb4e90ebcb3b7de'
- '6a3de26cec7b5b3e05090e85e970705454d9d749dcd4a2e1d35bee11d4e3637b')
+ '05fbb88877cdddc99ef25e48304d6e5ac236660c20925d461cb4e90ebcb3b7de')
# remove default hardening for building libraries
CPPFLAGS=${CPPFLAGS/-D_FORTIFY_SOURCE=2/}
@@ -36,15 +35,6 @@ pkgver() {
git describe --exclude '*.*.9000' | sed 's/^glibc-//; s/-/.r/; s/-/./'
}
-prepare() {
- cd glibc
- # revert commit breaking proprietary electron apps for now; this is lld's fault
- # but it's too serious a regression to break software in the wild until users
- # have a solution. See https://bugs.archlinux.org/task/59550 and
- # https://github.com/electron/electron/issues/13972#issuecomment-411532741
- patch -p1 -i ../0001-Revert-elf-Correct-absolute-SHN_ABS-symbol-run-time-.patch
-}
-
build() {
mkdir -p build
cd build