summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRyo Munakata2021-08-14 12:19:34 +0900
committerRyo Munakata2021-08-14 12:19:34 +0900
commit2ce38f77321ab76db8e0023b1ed91d236240c649 (patch)
treecaf6bf8d9be35cc395956c147f3df6076b0f366c /PKGBUILD
parentec2bdb2920e5a64be13867d3b7cdf662ba6ddec5 (diff)
downloadaur-2ce38f77321ab76db8e0023b1ed91d236240c649.tar.gz
Rebased on glmark2
https://aur.archlinux.org/packages/glmark2/
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 19 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f235c6612747..7b7f63d23eff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,20 @@
# Maintainer: Ryo Munakata <afpacket@gmail.com>
+# Rebased on glmark2 (https://aur.archlinux.org/packages/glmark2/)
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Contributor: farseerfc <farseerfc@gmail.com>
pkgname=glmark2-git
-pkgver=r870.b949d5f
+pkgver=r960.ca8de51
pkgrel=1
-pkgdesc="OpenGL (ES) 2.0 benchmark (X11, Wayland, DRM)"
-arch=('i686' 'x86_64')
-url="https://launchpad.net/glmark2"
-license=('GPL3')
-depends=('libjpeg-turbo' 'libpng12' 'libx11' 'libxcb' 'wayland' 'libgl' 'libgles')
-makedepends=('git' 'python2')
+pkgdesc="An OpenGL 2.0 and ES 2.0 benchmark (X11, Wayland, DRM)"
+arch=('x86_64' 'aarch64')
+url="https://github.com/glmark2/glmark2"
+license=('GPL' 'custom')
+depends=('libjpeg-turbo' 'libpng' 'libx11' 'mesa' 'systemd-libs' 'libgl' 'libgles' 'wayland' 'egl-wayland')
+makedepends=('meson' 'systemd' 'wayland-protocols')
conflicts=('glmark2')
provides=('glmark2')
-source=(
- "$pkgname"::'git://github.com/glmark2/glmark2.git'
- )
-md5sums=(
- 'SKIP'
- )
+source=("$pkgname"::'git://github.com/glmark2/glmark2.git')
+md5sums=('SKIP')
# GLMARK2 features
GM2_FLAVORS="x11-gl,x11-glesv2,wayland-gl,wayland-glesv2,drm-gl,drm-glesv2"
@@ -25,19 +24,15 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "${srcdir}/${pkgname}"
-}
-
build() {
- cd "${srcdir}/${pkgname}"
- python2 ./waf configure \
- --prefix=/usr \
- --with-flavors=${GM2_FLAVORS}
- python2 ./waf -j4
+ pwd
+ arch-meson "$pkgname" build -Dflavors=${GM2_FLAVORS}
+ meson compile -C build
}
package() {
- cd "${srcdir}/${pkgname}"
- DESTDIR="${pkgdir}" python2 ./waf install
+ DESTDIR="$pkgdir" meson install -C build
+
+ cd "$pkgname"
+ install -Dm644 COPYING.SGI -t "$pkgdir/usr/share/licenses/$pkgname"
}