summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorp4block2017-05-08 03:07:03 +0200
committerp4block2017-05-08 03:07:03 +0200
commit95661cbe1d5f059cece3b098e9894618bcd43eb5 (patch)
tree007904fad91b3b3982344eecc1ea4cbbc41c8de2 /PKGBUILD
downloadaur-95661cbe1d5f059cece3b098e9894618bcd43eb5.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d511874930ee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Pablo Moyano (p4block)
+pkgname=glmviz-git
+pkgver=1.0
+pkgrel=1
+pkgdesc='High framerate, dB correct OpenGL music visualizer with FiFo buffers and PulseAudio input support'
+arch=('x86_64')
+url='https://github.com/hannesha/GLMViz'
+license=('GPL3')
+depends=(glm fftw glfw-x11 libconfig)
+optdepends=(pulseaudio)
+source=("git+https://github.com/hannesha/GLMViz.git")
+md5sums=('SKIP')
+
+build() {
+
+ cd "${srcdir}/GLMViz"
+ mkdir -p build
+ cd build
+ cmake ..
+
+}
+
+package() {
+ cd "${srcdir}/GLMViz/build"
+ make DESTDIR=${pkgdir} install
+
+}