summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKevin Yue2020-02-21 23:23:13 +0800
committerKevin Yue2020-02-21 23:23:13 +0800
commit91b17f69afb9055380432dceea6dc4a1156dcb59 (patch)
tree422de47270acedd6734eea96e5629b7bc20e855d /PKGBUILD
downloadaur-91b17f69afb9055380432dceea6dc4a1156dcb59.tar.gz
Release 1.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d5173452d547
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Keinv Yue <yuezk001@gmail.com>
+
+pkgname=globalprotect-openconnect
+_gitname=GlobalProtect-openconnect
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A GlobalProtect VPN client (GUI) for Linux based on Openconnect and built with Qt5, supports SAML auth mode."
+arch=(x86_64)
+url="https://github.com/yuezk/${_gitname}"
+license=('GPL3')
+depends=(qt5-base qt5-webengine qt5-websockets)
+makedepends=()
+source=(
+ "${_gitname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
+ "https://github.com/itay-grudev/SingleApplication/archive/v3.0.19.tar.gz"
+)
+
+sha256sums=('SKIP' 'SKIP');
+
+prepare() {
+ mv "$srcdir/SingleApplication-3.0.19" -T "$srcdir/${_gitname}-${pkgver}/singleapplication"
+}
+
+build() {
+ cd "$srcdir/${_gitname}-${pkgver}"
+ qmake CONFIG+=release "${srcdir}/${_gitname}-${pkgver}/GlobalProtect-openconnect.pro"
+ make
+}
+
+package() {
+ cd "$srcdir/${_gitname}-${pkgver}"
+ make INSTALL_ROOT="$pkgdir/" install
+}