summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormrxx2018-11-04 16:55:08 +0100
committermrxx2018-11-04 16:55:08 +0100
commit05664f9d603bc1fc019b16afdd61af8eed468a2a (patch)
treee73f1c5caeef4f6e256186ba1f89240757f37f64 /PKGBUILD
downloadaur-05664f9d603bc1fc019b16afdd61af8eed468a2a.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..02cfc7f0011d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: mrxx <mrxx at cyberhome dot at>
+
+_debpkg=gmchess
+pkgname=gmchess-bin
+pkgver=0.29.6
+pkgrel=1
+pkgdesc="Play Chinese chess (Xiangqi) against a human opponent or the computer"
+arch=("i686" "x86_64")
+url="http://www.xqbase.com/"
+license=('GPL2')
+depends=('gtkmm' 'eleeye-bin')
+conflicts=('gmchess')
+makedepends=('libarchive')
+source_x86_64=("http://security.ubuntu.com/ubuntu/pool/universe/g/gmchess/${_debpkg}_${pkgver}-3_amd64.deb")
+source_i686=("http://security.ubuntu.com/ubuntu/pool/universe/g/gmchess/${_debpkg}_${pkgver}-3_i386.deb")
+sha1sums_i686=('cb855268b688189d52be9b42febfc31be3962e2f')
+sha1sums_x86_64=('b2bd7d9167901f057a7e2307d282055184915b91')
+
+prepare() {
+ bsdtar xf data.tar.xz
+}
+
+package(){
+ install -d $pkgdir/usr/bin
+ install -d $pkgdir/usr/share
+ install -Dm755 $srcdir/usr/games/gmchess $pkgdir/usr/bin
+ cp -r "$srcdir/usr/share" "$pkgdir/usr/"
+}