summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander F. Rødseth2019-03-27 10:18:16 +0100
committerAlexander F. Rødseth2019-03-27 10:18:16 +0100
commit212ac07b1e65f482d469b13f669f312d2acc2723 (patch)
treeb78b11eca99d5b1380881b05eb2e0897fda7a18a /PKGBUILD
downloadaur-212ac07b1e65f482d469b13f669f312d2acc2723.tar.gz
Move from [community] to AUR in connection with the spring cleaning
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6f5b98dc06d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer:
+# Contributor: Alexander F. Rødseth <xyproto@archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Tobias Kieslich <tobias@archlinux.org>
+
+pkgname=gmpc
+pkgver=11.8.16
+pkgrel=6
+pkgdesc='MPD client'
+arch=(x86_64)
+url='https://gmpclient.org/home'
+license=(GPL)
+depends=(gtk2 libmpd libsoup sqlite xdg-utils)
+makedepends=(gob2 intltool vala)
+source=("http://download.sarine.nl/Programs/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.gz")
+sha256sums=('a69414f35396846733632ca9619921d7acda537ffd6d49bd84b444945cb76b2c')
+
+prepare() {
+ sed -i 's/GNOME;AudioVideo;/GTK;AudioVideo;Player;/' \
+ "$pkgname-$pkgver/data/gmpc.desktop.in"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ ./configure --prefix=/usr --disable-unique
+ make CFLAGS+='-lm'
+}
+
+package() {
+ make -C "$pkgname-$pkgver" DESTDIR="$pkgdir" install
+}
+
+# vim: ts=2 sw=2 et: