summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdrian Perez de Castro2019-02-16 01:08:52 +0200
committerAdrian Perez de Castro2019-02-16 01:08:52 +0200
commit0ed8d6297893a6e79b7d99a1e876e49f681f9351 (patch)
treee3a23f1dc6f7d089aef678c4ee9098e1e0008a73 /PKGBUILD
parent719df8ebc22e5c455a2ac2ed6f3b7fd538378f1c (diff)
downloadaur-0ed8d6297893a6e79b7d99a1e876e49f681f9351.tar.gz
Fix build due to missing -pthread compiler/linker flags
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 072136496242..462d6e99910f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
#
pkgname=gn-git
pkgdesc='Meta-build system which generates Ninja build files'
-pkgver=r1525.5519dc2f
+pkgver=r1531.1ab6fa2c
pkgrel=1
license=('BSD')
arch=('x86_64' 'i686')
@@ -28,7 +28,11 @@ prepare () {
build () {
cd gn
- CC=cc CXX=c++ AR=ar python2 build/gen.py --use-lto --no-strip
+ CC=cc CXX=c++ AR=ar \
+ CFLAGS="${CFLAGS} -pthread" \
+ CXXFLAGS="${CXXFLAGS} -pthread" \
+ LDFLAGS="${LDFLAGS} -pthread" \
+ python2 build/gen.py --use-lto --no-strip
ninja -C out
}