summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRod Kay2018-09-07 13:31:04 +1000
committerRod Kay2018-09-07 13:31:04 +1000
commit854ad789d48aed460047f4e1496131b6caf06e9d (patch)
tree0ec8a1433f52d518534edfb99bbd9ea31989d325 /PKGBUILD
downloadaur-854ad789d48aed460047f4e1496131b6caf06e9d.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c78c6521e327
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Rod Kay <charlie5 on #ada at freenode.net>
+
+pkgname=gnatcoll-core
+pkgver=2018
+pkgrel=1
+
+pkgdesc='Gnat components collection - Core packages.'
+url='https://github.com/AdaCore/gnatcoll-core/'
+arch=('i686' 'x86_64')
+license=('GPL')
+
+depends=('gcc-ada' 'libgpr')
+makedepends=('gprbuild')
+
+provides=('gnatcoll')
+conflicts=('gnatcoll')
+
+source=('http://mirrors.cdn.adacore.com/art/5b0819dfc7a447df26c27a99')
+sha1sums=('213105933eb2deb4d08f6b5beab518ad6c70fbac')
+
+
+build()
+{
+ cd gnatcoll-core-gpl-2018-src
+
+ make setup BUILD=PROD prefix=/usr
+ make PROCESSORS="$(nproc)" GPRBUILD_OPTIONS=-R
+}
+
+
+package()
+{
+ cd gnatcoll-core-gpl-2018-src
+
+ # Make one install at a time to avoid GPRinstall reading/writing to
+ # the same installed project files at the same time.
+ make prefix="$pkgdir/usr" install -j1
+}