summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPierre-Marie de Rodat2021-01-24 16:33:35 +0100
committerPierre-Marie de Rodat2021-01-24 16:34:32 +0100
commitf88e3c162b538bba09204d7eaa5cf341291b3ef4 (patch)
treee155406f4ad797efcf730efc44663e46a46f1105 /PKGBUILD
parent41eb3d5f996ff2c0cd76b002cbd1d34894ca8414 (diff)
downloadaur-f88e3c162b538bba09204d7eaa5cf341291b3ef4.tar.gz
Remove the new GNATCOL.OS.* packages
See the TODO in prepare().
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 16 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f1dd0a4b6782..8c888c78ee9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Pierre-Marie de Rodat <pmderodat on #ada at freenode.net>
pkgname=gnatcoll-core-git
-pkgver=r2835.ed921e27
-pkgrel=2
+pkgver=r3121.78b9de8c
+pkgrel=1
pkgdesc='GNAT Components Collection - Core packages'
url='https://github.com/AdaCore/gnatcoll-core/'
@@ -15,8 +15,10 @@ makedepends=('git' 'gprbuild')
provides=('gnatcoll-core')
conflicts=('gnatcoll-core' 'gnatcoll')
-source=('git+https://github.com/AdaCore/gnatcoll-core.git')
-sha1sums=('SKIP')
+source=('git+https://github.com/AdaCore/gnatcoll-core.git'
+ 'remove-os.patch')
+sha1sums=('SKIP'
+ '5e22130f6cb04bfdffb930c29e0abbda7be53514')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -25,6 +27,16 @@ pkgver() {
"$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+
+ # TODO: The new GNATCOLL.OS.* packages depend on new runtime features (for
+ # instance: Interfaces.C.unsigned_long_long). These will be available only
+ # in future GCC releases (11 and later), so just do without them for now.
+ patch -Np1 -i "$srcdir/remove-os.patch"
+ rm src/os/gnatcoll-os-*
+}
+
build()
{
cd "$srcdir/${pkgname%-git}"