summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRod Kay2019-06-23 12:57:01 +1000
committerRod Kay2019-06-23 12:57:01 +1000
commit25e2e8a05e34374dddd3d76bb96c4aa2c8cef341 (patch)
treefb82221bd0a0abb34f66c9d9f0889b618c40390d /PKGBUILD
parent1c2a208b0e32af623968b8d00f303c2fe6a49a83 (diff)
downloadaur-25e2e8a05e34374dddd3d76bb96c4aa2c8cef341.tar.gz
Update to 2019.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1d74454bb4e5..28c5c3515e20 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,36 @@
# Maintainer: Rod Kay <charlie5 on #ada at freenode.net>
pkgname=gnatcoll-gnatinspect
-pkgver=2018
-pkgrel=2
+pkgver=2019
+pkgrel=1
pkgdesc='GNAT Components Collection - the gnatinspect tool.'
url='https://github.com/AdaCore/gnatcoll-db/'
arch=('i686' 'x86_64')
license=('GPL')
-depends=('gnatcoll-readline>=2018' 'gnatcoll-xref>=2018')
-makedepends=('gprbuild>=2018')
+depends=('gnatcoll-readline' 'gnatcoll-xref')
+makedepends=('gprbuild')
+
+source=('https://github.com/AdaCore/gnatcoll-db/archive/master.zip')
+sha1sums=('dc4186e802daa71ab88170cd91708738c170d2fb')
-source=('http://mirrors.cdn.adacore.com/art/5b0ce9cbc7a4475263382be6')
-sha1sums=('85c90002bb506e3e72e38d2e6604734402d23a32')
build()
{
- cd "$srcdir/gnatcoll-db-gpl-2018-src/gnatinspect"
+ cd "$srcdir/gnatcoll-db-master/gnatinspect"
make setup BUILD=PROD prefix=/usr
make -j1 GPRBUILD_OPTIONS=-R
}
+
package()
{
- cd "$srcdir/gnatcoll-db-gpl-2018-src/gnatinspect"
+ cd "$srcdir/gnatcoll-db-master/gnatinspect"
# Make one install at a time to avoid GPRinstall reading/writing to
# the same installed project files at the same time.
+ #
make prefix="$pkgdir/usr" install -j1
}