summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRod Kay2021-06-21 16:25:00 +1000
committerRod Kay2021-06-21 16:25:00 +1000
commite7159578da913d8382cb8195e27db9103d0a8456 (patch)
tree93d6f06772773430070ee65529947ad7bc029483 /PKGBUILD
parent8deb4063072c6f7c9f0b14fccc6db45bc8f2cf97 (diff)
downloadaur-e7159578da913d8382cb8195e27db9103d0a8456.tar.gz
Install licenses.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 11 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c358edf4de68..29a76dfd9ee6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ _repo_name=gnatcoll-db
pkgdesc='GNAT Components Collection - Postgres database support'
url='https://github.com/AdaCore/gnatcoll-db/'
arch=('i686' 'x86_64')
-license=('GPL')
+license=('GPL3' 'custom')
depends=('gnatcoll-core' 'gnatcoll-sql' 'postgresql')
makedepends=('gprbuild')
@@ -33,4 +33,14 @@ package()
# Make one install at a time to avoid GPRinstall reading/writing to
# the same installed project files at the same time.
make prefix="$pkgdir/usr" install -j1
+
+ # Install the license.
+ install -D -m644 \
+ "../COPYING3" \
+ "$pkgdir/usr/share/licenses/$pkgname/COPYING3"
+
+ # Install the custom license.
+ install -D -m644 \
+ "../COPYING.RUNTIME" \
+ "$pkgdir/usr/share/licenses/$pkgname/COPYING.RUNTIME"
}