summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRod Kay2019-06-23 12:59:54 +1000
committerRod Kay2019-06-23 12:59:54 +1000
commit34865a4d82ce9a4bb33cf9b05c8dde08fdf0828e (patch)
tree258116c814fd5110d52ebf5b5717f4a84d633e8f /PKGBUILD
parent10d8fcbb22b0472c6c724392797cb6dd25d69d6f (diff)
downloadaur-34865a4d82ce9a4bb33cf9b05c8dde08fdf0828e.tar.gz
Update to 2019.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b9f946c2f752..d58dfe53e79e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,36 @@
# Maintainer: Rod Kay <charlie5 on #ada at freenode.net>
pkgname=gnatcoll-xref
-pkgver=2018
-pkgrel=2
+pkgver=2019
+pkgrel=1
pkgdesc='GNAT Components Collection - Tool to support parsing *.ali and *.gli files.'
url='https://github.com/AdaCore/gnatcoll-db/'
arch=('i686' 'x86_64')
license=('GPL')
-depends=('gnatcoll-iconv>=2018' 'gnatcoll-sqlite>=2018')
-makedepends=('gprbuild>=2018')
+depends=('gnatcoll-iconv' 'gnatcoll-sqlite')
+makedepends=('gprbuild')
+
+source=('https://github.com/AdaCore/gnatcoll-db/archive/master.zip')
+sha1sums=('dc4186e802daa71ab88170cd91708738c170d2fb')
-source=('http://mirrors.cdn.adacore.com/art/5b0ce9cbc7a4475263382be6')
-sha1sums=('85c90002bb506e3e72e38d2e6604734402d23a32')
build()
{
- cd "$srcdir/gnatcoll-db-gpl-2018-src/xref"
+ cd "$srcdir/gnatcoll-db-master/xref"
make setup BUILD=PROD prefix=/usr
make -j1 GPRBUILD_OPTIONS=-R
}
+
package()
{
- cd "$srcdir/gnatcoll-db-gpl-2018-src/xref"
+ cd "$srcdir/gnatcoll-db-master/xref"
# Make one install at a time to avoid GPRinstall reading/writing to
# the same installed project files at the same time.
+ #
make prefix="$pkgdir/usr" install -j1
}