summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRod Kay2021-06-21 15:41:07 +1000
committerRod Kay2021-06-21 15:41:07 +1000
commite8a517c0410426e2cdb88589bb5b4b88651628de (patch)
tree29ae8b1f13e27aa1431695bc168b338af61d13b2 /PKGBUILD
parent41a28c8634210dd30db911dba329a563b41306aa (diff)
downloadaur-e8a517c0410426e2cdb88589bb5b4b88651628de.tar.gz
Install licenses.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 11 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 61681e7e7957..f72cb6d764d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ _repo_name=gnatcoll-db
pkgdesc='GNAT Components Collection - Tool to support parsing *.ali and *.gli files.'
url='https://github.com/AdaCore/gnatcoll-db/'
arch=('i686' 'x86_64')
-license=('GPL')
+license=('GPL3' 'custom')
depends=('gnatcoll-core' 'gnatcoll-iconv' 'gnatcoll-sqlite')
makedepends=('gprbuild')
@@ -33,4 +33,14 @@ package()
# Make one install at a time to avoid GPRinstall reading/writing to
# the same installed project files at the same time.
make prefix="$pkgdir/usr" install -j1
+
+ # Install the license.
+ install -D -m644 \
+ "../COPYING3" \
+ "$pkgdir/usr/share/licenses/$pkgname/COPYING3"
+
+ # Install the custom license.
+ install -D -m644 \
+ "../COPYING.RUNTIME" \
+ "$pkgdir/usr/share/licenses/$pkgname/COPYING.RUNTIME"
}