summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortuberry2020-11-18 00:37:00 +0800
committertuberry2020-11-18 00:37:00 +0800
commit5a7bc3b426311734522460c6752e439215458fe8 (patch)
tree14017bdb74409ff8b060635bedc6406f9ce6d60b /PKGBUILD
downloadaur-5a7bc3b426311734522460c6752e439215458fe8.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e04ce4c2308e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: tuberry
+
+_srcname="lakeside-dynamic-wallpaper"
+pkgname=gnome-backgrounds-lakeside-git
+pkgver=r3.88323e3
+pkgrel=1
+pkgdesc="Beautiful dynamic lakeside wallpaper for Gnome"
+url="https://github.com/dbasinge/${_srcname}"
+depends=("gnome-backgrounds")
+makedepends=("git")
+provides=("gnome-backgrounds-lakeside")
+license=("custom")
+arch=("any")
+source=("git+${url}")
+md5sums=("SKIP")
+
+pkgver() {
+ cd ${_srcname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd ${_srcname}
+
+ install -dm755 ${pkgdir}/usr/share/backgrounds/Lakeside
+ for file in Lakeside/*; do
+ if [[ "$file" == *"preview"* ]]; then
+ continue;
+ fi
+ install -Dm644 $file ${pkgdir}/usr/share/backgrounds/Lakeside
+ done
+
+ install -Dm644 desktop-backgrounds-lakeside.xml ${pkgdir}/usr/share/gnome-background-properties/lakeside.xml
+}