summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPellegrino Prevete2023-06-28 12:46:57 +0200
committerPellegrino Prevete2023-06-28 12:46:57 +0200
commitea7e5ec6fd0376f081fdbb05a11d6a8c023cf5fa (patch)
treee9a2545cf9820776dc3783e506cfc4185f4e1ea2 /PKGBUILD
parentb7ea4921a0fdb7c7469b8e3e9e197b87ef6b0438 (diff)
downloadaur-ea7e5ec6fd0376f081fdbb05a11d6a8c023cf5fa.tar.gz
update to 44
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD62
1 files changed, 47 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2713b4b611df..9b046278688e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,49 @@
-pkgname=gnome-boxes-git
+# Maintainer: Pellegrino Prevete <pellegrinoprevete@gmail.com>
+
_pkgname=gnome-boxes
-pkgver=3.37.90+158+g478d3c69
+pkgname="${_pkgname}-git"
+pkgver=44.beta+73+g18a7d511
pkgrel=1
-pkgdesc="Simple GNOME application to access remote or virtual systems"
-arch=(x86_64)
+pkgdesc="Simple GNOME application to access virtual systems"
+arch=(
+ x86_64
+ i686
+ pentium4
+ aarch64
+ armv7h)
url="https://wiki.gnome.org/Apps/Boxes"
license=(LGPL)
-depends=('cdrtools' 'edk2-ovmf' 'freerdp' 'gtksourceview4' 'gtk-vnc' 'libarchive' 'libgudev' 'libhandy' 'libosinfo'
- 'libsecret' 'libvirt-glib' 'mtools' 'qemu' 'spice-gtk' 'tracker3' 'webkit2gtk')
-makedepends=('git' 'gobject-introspection' 'yelp-tools' 'meson' 'spice-protocol' 'vala')
-provides=('gnome-boxes')
-conflicts=('gnome-boxes')
-source=("git+https://gitlab.gnome.org/GNOME/gnome-boxes.git"
+depends=(
+ 'cdrtools'
+ 'edk2-ovmf'
+ 'libarchive'
+ 'libgudev'
+ 'libhandy'
+ 'libosinfo'
+ 'libsecret'
+ 'libsoup3'
+ 'libvirt-glib'
+ 'mtools'
+ 'qemu-desktop'
+ 'spice-gtk'
+ 'tracker3'
+ 'webkit2gtk-4.1'
+)
+makedepends=(
+ 'appstream-glib'
+ 'git'
+ 'gobject-introspection'
+ 'meson'
+ 'spice-protocol'
+ 'vala'
+ 'yelp-tools'
+)
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+groups=(
+ gnome-extra
+ gnome-extra-git)
+source=("git+https://gitlab.gnome.org/GNOME/${_pkgname}.git"
"git+https://gitlab.gnome.org/GNOME/gtk-frdp.git"
"git+https://gitlab.gnome.org/GNOME/libhandy.git"
"git+https://gitlab.gnome.org/felipeborges/libovf-glib.git")
@@ -21,22 +53,22 @@ b2sums=('SKIP'
'SKIP')
pkgver() {
- cd $_pkgname
+ cd "${_pkgname}"
git describe --tags | sed 's/^v//;s/-/+/g'
}
prepare() {
- cd $_pkgname
+ cd "${_pkgname}"
git submodule init
git submodule set-url subprojects/gtk-frdp "$srcdir/gtk-frdp"
git submodule set-url subprojects/libhandy "$srcdir/libhandy"
git submodule set-url subprojects/libovf-glib "$srcdir/libovf-glib"
- git submodule update
+ git -c protocol.file.allow=always submodule update
}
build() {
- arch-meson $_pkgname build
+ arch-meson "${_pkgname}" build
meson compile -C build
}
@@ -45,5 +77,5 @@ check() {
}
package() {
- DESTDIR="$pkgdir" meson install -C build
+ meson install -C build --destdir "${pkgdir}"
}