summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoryjun1232020-04-24 17:41:59 +0800
committeryjun1232020-04-24 17:41:59 +0800
commitc87587f00e118a17305bd7f77ab92ed48c16f3b5 (patch)
treeb13702c9ce09fe545fae51cc239f0b51cc0ac03f /PKGBUILD
downloadaur-c87587f00e118a17305bd7f77ab92ed48c16f3b5.tar.gz
init commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7a4fc2dd8335
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: yjun <jerrysteve1101@gmail.com>
+
+pkgname=gnome-breakout-bin
+_pkgname=gnome-breakout
+pkgver=0.5.3
+pkgrel=1
+pkgdesc="Clone of the classic game Breakout, written for GNOME"
+arch=('x86_64')
+url="http://www.users.on.net/~mipearson/"
+license=('GPL3')
+depends=('goocanvas' 'libgnome-games-support' 'gtk3' 'gdk-pixbuf2' 'cairo')
+source=(gnome-breakout.deb::"http://http.us.debian.org/debian/pool/main/g/${_pkgname}/${_pkgname}_${pkgver}-7_amd64.deb")
+sha256sums=('d4b3013cd99c6585ce617989e4339aadf578fd10bc56b6b1c90b89d4acd39a35')
+package() {
+ tar -xvf ${srcdir}/data.tar.xz -C ${pkgdir}/
+ mkdir ${pkgdir}/usr/bin
+ mv ${pkgdir}/usr/games/gnome-breakout ${pkgdir}/usr/bin
+ rmdir ${pkgdir}/usr/games
+ install -Dm 644 ${pkgdir}/usr/share/pixmaps/gnome-breakout.png ${pkgdir}/usr/share/icons/hicolor/48x48/gnome-breakout.png
+ sed -i 's/Icon=gnome-breakout.png/Icon=gnome-breakout/g' ${pkgdir}/usr/share/applications/gnome-breakout.desktop
+}