summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKevin Majewski2021-12-04 20:11:31 +0100
committerKevin Majewski2021-12-04 20:11:31 +0100
commita6208ac993851c9266d2b9991a6d487008180e8f (patch)
treee31047a7413cce5c972cc3c15d37a258146b8216 /PKGBUILD
parentb0edeff61c505219451f39e02f2d379ebeb854ae (diff)
downloadaur-a6208ac993851c9266d2b9991a6d487008180e8f.tar.gz
Update dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 12 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ecd7fa28000e..596d55469ca0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,25 @@
-# Maintainer: Philip Goto <philip.goto@gmail.com>
-# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
-# Contributor: Jan de Groot <jgc@archlinux.org>
-
-pkgname=gnome-calculator-git
-pkgver=3.36.0.r15.ge71e03f3
+_pkgname=gnome-calculator
+pkgname=${_pkgname}-git
+pkgver=41.0.r74.g375e3220
pkgrel=1
pkgdesc="GNOME Scientific calculator"
url="https://wiki.gnome.org/Apps/Calculator"
-arch=(i686 x86_64 armv7h aarch64)
+arch=(aarch64 armv7h i686 x86_64)
license=(GPL)
-depends=(gtksourceview4 libmpc libgee)
-makedepends=(yelp-tools vala git appstream-glib meson)
-provides=(gnome-calculator)
-conflicts=(gnome-calculator)
-groups=(gnome)
-source=("git+https://gitlab.gnome.org/GNOME/gnome-calculator.git")
-sha256sums=('SKIP')
+depends=(gtk4 gtksourceview5 libadwaita libgee libmpc)
+makedepends=(appstream-glib git meson vala yelp-tools)
+provides=(${_pkgname})
+conflicts=(${_pkgname})
+source=("git+https://gitlab.gnome.org/GNOME/${_pkgname}.git")
+b2sums=('SKIP')
pkgver() {
- cd gnome-calculator
+ cd ${_pkgname}
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- arch-meson gnome-calculator build
+ arch-meson ${_pkgname} build
ninja -C build
}