summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSam Burgos2018-06-26 17:39:24 -0600
committerSam Burgos2018-06-26 17:39:24 -0600
commit5170131a28e9278e2bed782183510206114671d8 (patch)
tree719a6f1fc13a91d702fa704912c60e3bdb83aee6 /PKGBUILD
parent8147a4e83d440ecc3c9b340cb0668d34586b6985 (diff)
downloadaur-5170131a28e9278e2bed782183510206114671d8.tar.gz
standarized PKGBUILD to newer template as well as make a cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 14 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1d35e51c2ad3..452c03fb6be9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,16 +6,23 @@ pkgver=3.28.2
pkgrel=2
pkgdesc="Simple and beautiful calendar application designed to perfectly fit the GNOME desktop. With Linux Mint patches"
url="https://wiki.gnome.org/Apps/Calendar"
-arch=(x86_64)
-license=(GPL)
-depends=(gsettings-desktop-schemas libdazzle)
-makedepends=(python appstream-glib git meson gtk-doc evolution evolution-data-server)
+arch=('x86_64')
+license=('GPL')
+depends=('gsettings-desktop-schemas'
+ 'libdazzle')
+makedepends=('appstream-glib'
+ 'evolution'
+ 'evolution-data-server'
+ 'git'
+ 'gtk-doc'
+ 'meson'
+ 'python')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
_commit=c4d1f984758e77787ef97b71fe2dede8477809c2 # tags/3.28.2^0
source=("git+https://gitlab.gnome.org/GNOME/gnome-calendar.git#commit=$_commit"
- null-icaltime.diff
- add_cinnamon_settings_online_support.patch)
+ "null-icaltime.diff"
+ "add_cinnamon_settings_online_support.patch")
sha256sums=('SKIP'
'c1aa738a4ff275f725d0aa5406312600503b2b59270448a9e6b30b82a924dc27'
'2445f754a044dd1ccb8c948b5d5b43248b61ec3570fc76416f74148abc5abf4d')
@@ -30,7 +37,7 @@ prepare() {
}
build() {
- arch-meson $_pkgname build -D gtk_doc=true
+ arch-meson "${_pkgname}" build -D gtk_doc=true
ninja -C build
}