summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSebastian Krzyszkowiak2019-08-10 17:33:07 +0200
committerSebastian Krzyszkowiak2019-08-10 17:33:07 +0200
commit8bd1006073c348b985f64e4f353a712337a0e06e (patch)
treeea87b0182b6c279a152389fa534490cc4de16687 /PKGBUILD
downloadaur-8bd1006073c348b985f64e4f353a712337a0e06e.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f6f93f848a49
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Sebastian Krzyszkowiak <dos@dosowisko.net>
+# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+
+pkgname=gnome-clocks-git
+pkgver=3.33.1.r0.gd52b2bc
+pkgrel=1
+pkgdesc="Clocks applications for GNOME"
+url="https://wiki.gnome.org/Apps/Clocks"
+arch=(x86_64)
+license=(GPL)
+depends=(gtk3 libcanberra libgweather gnome-desktop geoclue2 geocode-glib gsound)
+makedepends=(vala gobject-introspection yelp-tools git meson)
+groups=(gnome)
+provides=(gnome-clocks)
+conflicts=(gnome-clocks)
+source=("git+https://gitlab.gnome.org/GNOME/gnome-clocks.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd gnome-clocks
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ arch-meson gnome-clocks build
+ ninja -C build
+}
+
+check() {
+ meson test -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}