summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormax.bra2019-10-23 07:41:13 +0200
committermax.bra2019-10-23 07:41:13 +0200
commite9345821d1721f2e394b01f88b6699d61fb4e4b3 (patch)
tree9f2e6aec4b8395caeb18ad3e0bddcd7c00b2c63e /PKGBUILD
parent9f54f2d34ae263403efde1490618165259d7555d (diff)
downloadaur-e9345821d1721f2e394b01f88b6699d61fb4e4b3.tar.gz
distutils python package guidelines
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 4 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ada07a2f98e6..d9b1473c1e44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,29 +4,25 @@
pkgname=gnome-gmail
pkgver=2.7
_pkgbranch=master
-pkgrel=1
+pkgrel=2
pkgdesc="It allows desktop mail actions, such as 'Send File as Email' or web 'mailto' links, to be handled by the Gmail web client."
arch=('any')
url="https://davesteele.github.io/gnome-gmail/index.html"
license=('GPL2')
-depends=('python-gobject' 'python2-gnomekeyring' 'desktop-file-utils' 'python-setuptools' 'python-xdg' 'xdg-utils' 'python-six' 'libwnck3')
+depends=('python-gobject' 'python-keyring' 'desktop-file-utils' 'python-setuptools' 'python-xdg' 'xdg-utils' 'python-six' 'libwnck3')
optdepends=('nautilus-sendto: automatically upload an email with a file attachment from nautilus')
makedepends=('intltool')
source=(https://github.com/davesteele/gnome-gmail/archive/master/$pkgver.tar.gz)
md5sums=('934e610ecb01b9e3bad8524e01f88ba5')
install=$pkgname.install
-#prepare() {
-# cd "$srcdir"/$pkgname-$_pkgbranch
-#}
-
build() {
cd "$srcdir"/$pkgname-$_pkgbranch-$pkgver
- /usr/bin/python ./setup.py build
+ /usr/bin/python setup.py build
}
package() {
cd "$srcdir"/$pkgname-$_pkgbranch-$pkgver
- /usr/bin/python ./setup.py install --root="$pkgdir"
+ /usr/bin/python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}