summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichal Wojdyla2021-07-16 07:05:58 +0200
committerMichal Wojdyla2021-07-16 07:05:58 +0200
commit39fc75fb1d3d559eb4676f23e23a6be84c126b46 (patch)
tree28588e87f95d5a14541476fd67b0c4d103b127f7 /PKGBUILD
parent2f606c3d09c6b241f1390e64070a36db8af03234 (diff)
downloadaur-39fc75fb1d3d559eb4676f23e23a6be84c126b46.tar.gz
update to latest commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 33 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1976d5fdb65c..fddcc8c1313f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,4 @@
-# $Id: PKGBUILD 183396 2013-04-21 22:10:19Z heftig $
-# Maintainer: Colin Keenan <colinnkeenan at gmail dot com>
+# Contributor: Colin Keenan <colinnkeenan at gmail dot com>
# Contributor: Ionut Biru <ibiru@archlinux.org>
# The difference between this PKGBUILD and the one for gnome-search-tool is "depends..."
@@ -7,30 +6,46 @@
# It depends on nautilus-data instead, also available in AUR, and so avoids gnome-desktop
pkgname=gnome-search-tool-no-nautilus
-pkgver=3.6.0
-pkgrel=3
-pkgdesc="installs gnome-search-tool to search for files without nautilus or gnome-desktop"
-arch=(i686 x86_64)
-url="http://gnome.org"
-license=('GPL2')
-depends=('nautilus-data' 'libsm')
-makedepends=('intltool' 'yelp-tools')
-provides=('gnome-search-tool=3.6.0')
-install=gnome-search-tool.install
+pkgver=3.6.0+82+g4a8f34e
+pkgrel=1
+pkgdesc="Utility to search for files without nautilus or gnome-desktop"
+arch=(x86_64)
+url="https://gitlab.gnome.org/Archive/gnome-search-tool"
+license=(GPL2)
+depends=(nautilus-data libsm)
+makedepends=(intltool yelp-tools git gnome-common)
+provides=('gnome-search-tool')
conflicts=('gnome-search-tool')
-options=('!emptydirs')
-source=(http://download.gnome.org/sources/gnome-search-tool/${pkgver%.*}/gnome-search-tool-$pkgver.tar.xz)
-sha256sums=('a33000cd7d033be4ea50422f0f2cca611da5b79bd0f0875017f105a1bc177f42')
+_commit=4a8f34e050fb794852264cf54feb7d449dd15965 # master
+source=("git+https://gitlab.gnome.org/Archive/gnome-search-tool.git#commit=$_commit")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd gnome-search-tool
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd gnome-search-tool
+
+ # Fix configure
+ sed -i '/^AM_GNU_GETTEXT/d' configure.ac
+
+ NOCONFIGURE=1 ./autogen.sh
+}
build() {
- cd "gnome-search-tool-$pkgver"
+ cd gnome-search-tool
./configure --prefix=/usr --sysconfdir=/etc
make
}
+check() {
+ make -C gnome-search-tool check
+}
+
package() {
- cd "gnome-search-tool-$pkgver"
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" make -C gnome-search-tool install
}
# vim:set ts=2 sw=2 et: