summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorQue Quotion2018-03-21 16:52:03 +0900
committerQue Quotion2018-03-21 16:52:03 +0900
commit1fc07303dbe243e4eda93a5923e11e576a73d785 (patch)
tree3413c97318a3c3b2b0eab4891d740dbef06f68f0 /PKGBUILD
parent42876ed4a77f3e5aec6355d2d97021f737ab66cd (diff)
downloadaur-1fc07303dbe243e4eda93a5923e11e576a73d785.tar.gz
3.17.91 is no longer available from the PPA; 3.28.0 has landed in bionic
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 15 insertions, 35 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f8768c9c8996..0a649500ce13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,17 +11,17 @@
# vercheck-ppa: name=${pkgname%-*}, url=ppa:gnome3-team/gnome3-staging
pkgname=gnome-settings-daemon-elementary
-_use_ppa=true
+_use_ppa=false
_ppa_rel=0ubuntu0~bionic1
_ppa_ver=3.27.91
-_ubuntu_rel=0ubuntu0.1
-_ubuntu_ver=3.24.2
+_ubuntu_rel=0ubuntu1
+_ubuntu_ver=3.28.0
if [[ "${_use_ppa}" == "true" ]]; then
_commit=08c416c68f7becc75ea43723fc956436d4976e79 # tags/GNOME_SETTINGS_DAEMON_3_27_91^0
else
- _commit=2ff67385f2b7c7adb0ab438cb41d114235a8e40a # tags/GNOME_SETTINGS_DAEMON_3_24_2^0
+ _commit=5ac1a8240fb784cc92e2b394156153e34e21dab9 # tags/GNOME_SETTINGS_DAEMON_3_28_0^0
fi
-pkgver=3.27.91
+pkgver=3.28.0
pkgrel=1
pkgdesc="GNOME Settings Daemon (with elementary OS patch)"
url="https://gitlab.gnome.org/GNOME/gnome-settings-daemon"
@@ -50,7 +50,7 @@ sha512sums=('SKIP'
if [[ "${_use_ppa}" == "true" ]]; then
sha512sums+=('9203c13a2b8526dec82e838e46c62919cd2dd38224a8aca942bc3821cc662cee2dcc459241f363f047475dc7c4800616078201eb1a5e1e4ac6d003a0f3231fe3')
else
- sha512sums+=('f6d7746ab353be390682a791047819d11e94715620c62e0ab89c72752b8d134a25d8859e009b64f5e381472cc438e7167320fa7fde9ab9bc9fd037adbd0c5382')
+ sha512sums+=('fdbeef6092a78e56cfa939abc1f107c0ff3aa496e7a0bd8b0b80eb3c5d39f364cbdb145b146f29b9ce5d4e5e4c80c045751e1950932399020ff64fda35560f8c')
fi
pkgver() {
@@ -76,51 +76,31 @@ prepare() {
# Apply Elementary's patches
msg2 "Applying manage-dpms.patch ..."
patch -Np0 < ../manage-dpms.patch
-
- [[ "${_use_ppa}" == "true" ]] || NOCONFIGURE=1 ./autogen.sh
}
build() {
cd "${pkgname%-*}"
- if [[ "${_use_ppa}" == "true" ]]; then
- meson \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --libexecdir=/usr/lib/gnome-settings-daemon \
- -Dstatic-false=true \
- builddir
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --libexecdir=/usr/lib/gnome-settings-daemon \
+ -Dstatic-false=true \
+ builddir
- ninja -C builddir
+ ninja -C builddir
#"-Dstatic-false=true"
#According to the GNOME initiative the format should be -Dstatic-false
#meson says it needs to be followed by =bool
#Rediculous, utterly rediculous and probably wrong.
- else
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --libexecdir=/usr/lib/gnome-settings-daemon \
- --disable-static
-
- # https://bugzilla.gnome.org/show_bug.cgi?id=656231
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
-
- make
- fi
}
package() {
cd "${pkgname%-*}"
- if [[ "${_use_ppa}" == "true" ]]; then
- DESTDIR="${pkgdir}" ninja -C builddir install
- else
- make DESTDIR="${pkgdir}" install
- fi
+ DESTDIR="${pkgdir}" ninja -C builddir install
# Elementary is shipping these with pantheon-session-git; not sure how good an idea that is (upstream gsd could change before they can react)
#cd "${pkgdir}"
#for i in $(grep -Rl OnlyShowIn etc/xdg/autostart/); do